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1 

Introduction to the Dolby Atmos Conversion
Tool Software Guide
This documentation is for engineers, and others who work with Dolby Atmos content for cinema or
home theater. Use the conversion tool to convert one Dolby Atmos master file format to another, edit
or join masters as a composition, or perform other tool operations (such as applying frame-rate
conversion to a Dolby Atmos master file).

• New in this version
• Contacting Dolby

Introduction to the Dolby Atmos Conversion Tool Software Guide
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1.1 New in this version
Dolby Atmos Conversion Tool v2.0 includes new features and improvements, including a new graphical user
interface (GUI) (GUI) that supports editing, joining, and converting masters.

1.1.1 System and installation updates
Dolby Atmos Conversion Tool v2.0 provides system and installation updates.

• Support on macOS Catalina (version 10.15.x)
• New application icon

Figure 1: Dolby Atmos Conversion Tool icon

1.1.2 New conversion and new composition workflows and GUI
Dolby Atmos Conversion Tool v2.0 has a new GUI with controls and menus to support and simplify
workflows for performing format and other conversions, and editing or joining Dolby Atmos masters.

New conversion and new composition workflows
The Conversion Tool supports two primary types of workflows, which you access from the Conversion Tool
home window.

Figure 2: Dolby Atmos Conversion Tool home window

New conversion
Create a new conversion to convert the format, frame rate, first frame of action (FFOA), or primary
language (Interoperable Master Format (IMF) immersive audio bitstream (IAB) only) of a master.

You perform conversions in the Conversion window.

New in this version
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Figure 3: Example of conversion window, with an imported master file

You can perform changes to the format, frame rate, FFOA, or primary language (IMF IAB only)
simultaneously or separately.

The length of a master file opened in the Conversion window is not altered if the master file starts and
ends on non-frame boundaries.

Note: Alternatively, you can create a new composition to perform a conversion in the
Composition window.

New composition

Create a new composition to edit, join, or convert one or more master files in the composition timeline.
Editing and joining masters are new features in the GUI.

You perform compositions in the Composition window.

Figure 4: Example of a composition with multiple master files in the master files list and composition
timeline

You can perform changes to the format, start time, frame rate, FFOA, or primary language (IMF IAB only)
simultaneously or separately.

Introduction to the Dolby Atmos Conversion Tool Software Guide
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When a file that starts or ends on subframe boundaries is imported into the Composition window, it is
extended with silence to the next frame boundary in either direction so that no underlying content is
trimmed. This is indicated by green lines at the start and/or end of each clip.

Menus and submenus focused on workflows

The Dolby Atmos Conversion Tool GUI now provides menus and submenus for managing and performing
conversion tasks. The available menus are dependent on the current window (home window, Conversion
window, or Composition window). The tool includes keyboard shortcuts for many menu commands.

Workflow features for a new conversion or new composition

This version includes features that apply to performing a new conversion or composition:

• Clicking in the empty, dotted area in the Conversion or Composition window opens the file browser,
where you can import a master.

• The metadata view displays detailed information about the master.
• The application includes copy and paste support of timecode values.
• The FFOA of the converted master can be excluded (set to Not included). This feature is supported by the

Dolby Atmos Conversion Tool GUI and command-line interface (CLI).
• The FFOA is now rounded to the nearest frame boundary if on a subframe.
• The last used import and save location are remembered when you close the Conversion Tool or use

another function. This helps to speed up workflows when using the same import and save locations.
• When the target format is .atmos, .wav (ADM BWF), or .mxf (IMF IAB), the output file name for a conversion

uses the source file name by default (Mac only).

Workflow features for a new composition only

This version includes features that apply to performing a new composition only:

• Joining and editing masters
• Setting the primary master in the GUI determines which master program-level metadata will be used

when multiple masters are joined together.
• Trimming a master
• Splitting a master
• Adding silence to a master
• Zooming view options for how one or more masters display in the timeline
• Advanced metadata view, which provides detailed information about a master file or clip in the timeline.

Additionally, the view can display the length of a silence clip.

New conversion and new composition workflows and GUI
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Figure 5: Advanced metadata section, with a master selected

1.1.3 Miscellaneous updates and fixes
Dolby Atmos Conversion Tool v2.0 includes miscellaneous updates and fixes.

Miscellaneous updates and fixes

Command-line improvements: The FFOA of the converted master can be excluded (set to not included). This
feature is supported by the GUI and CLI.

Note: The CLI no longer adds an FFOA by default if it has been undefined in the source master.

New .xml (pmstitch) file examples and location

Example .xml (pmstitch) files have been updated to better represent real-world workflow scenarios and needs.
Example files (and supporting media) are now available online, instead of being included with installation.

You can find examples and a link to supporting media files online at https://developerkb.dolby.com/
support/solutions/articles/16000103176-where-can-i-find-more-examples-of-pmstitch-xml-files-.

Dolby provides .xml (pmstitch) file examples for use when creating a new .xml configuration file for padding
(adding silence) a master, joining masters, or trimming a master. With the CLI, the examples can also be
used to create .xml files for other tool operations (such as converting the master file format).

1.2 Contacting Dolby
You can contact Dolby regarding this product and its supporting documentation.

If you have technical questions about this product, consult the knowledge base at https://
developerkb.dolby.com/support/home. For additional questions, refer to the community forum for the
Dolby Atmos Mastering Suite.

Introduction to the Dolby Atmos Conversion Tool Software Guide
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If you have questions or comments about this documentation, please send an email to 
documentation@dolby.com.
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Installing the Dolby Atmos Conversion Tool
package
You can install the Dolby Atmos Conversion Tool package on Linux, Mac, and Windows systems
qualified by Dolby.

• Dolby Atmos Conversion Tool package components
• System requirements
• Update considerations
• Installing the Dolby Atmos Conversion Tool package
• Launching the Dolby Atmos Conversion Tool
• Quitting the Dolby Atmos Conversion Tool application
• Accessing operation log information

Installing the Dolby Atmos Conversion Tool package
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2.1 Dolby Atmos Conversion Tool package components
The Dolby Atmos Conversion Tool package can include the Conversion Tool application (with a dedicated
GUI) and CLI, depending on the operating system.

Operating system Dolby Atmos Conversion Tool
application (with a dedicated user
interface (UI) window)

Dolby Atmos Conversion Tool
command-line application

Linux No Yes

Mac Yes Yes

Windows Yes Yes

2.2 System requirements
Before installing the Dolby Atmos Conversion Tool package, you should review system requirements and
compatibility information to verify that your system supports the release and that you are ready to begin
installation.

The Dolby Atmos Conversion Tool package applications have been qualified for use on these operating
systems only:

• Linux (Dolby Atmos Conversion Tool command-line application only):

• RedHat 7.3
• Ubuntu 16.04.3 LTS (Xenial Xerus)

• Mac:

• macOS Catalina (version 10.15.x)
• macOS Mojave (version 10.14.x)

• Windows: Windows 10 (64 bit)

2.3 Update considerations
Installing the Dolby Atmos Conversion Tool package overwrites a previously-installed version. Additionally,
example .xml (pmstitch) files and supporting media that were included with Conversion Tool v1.9 and earlier
are also overwritten.

Older logs (on Mac and Windows systems) and the preference file (on Mac only) are not overwritten. You can
navigate tot these files and delete them, if desired.

• v1.9 logs are located here:

• Mac: ~/Library/Logs/Dolby Laboratories/Atmos Conversion Tool
• Windows: C:\ProgramData\Dolby Laboratories\Atmos Conversion Tool\logs

• For Mac only, the v1.9 preference file (~Library/Preferences/com.dolby-laboratories.Dolby Atmos Conversion Tool.plist)
is located in the ~Library/Preferences/ folder.

2.4 Installing the Dolby Atmos Conversion Tool package
Install the Dolby Atmos Conversion Tool package on a Linux, Mac, or Windows system qualified by Dolby.

Dolby Atmos Conversion Tool package components
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2.4.1 Installing the Dolby Atmos Conversion Tool Debian package on a Linux
system
You can install the Dolby Atmos Conversion Tool Debian package on a Linux system (such as Ubuntu Xenial
Xerus) that is qualified by Dolby.

About this task

The Dolby Atmos Conversion Tool Debian package for Linux installs the Dolby Atmos Conversion Tool
command-line application. The package does not include the Dolby Atmos Conversion Tool application
(which has a dedicated UI window).

Procedure

1. Ensure that the Dolby Atmos Conversion Tool Debian package (.deb file) is on your Linux machine.

2. Open the terminal window.

3. Install the Dolby Atmos Conversion Tool package:

a) Execute one of these command lines:

sudo dpkg -i dolby-atmos-conversion-tool-2.X.X.xxxxxxx-Linux.deb (where xxxxxxx is the build number)

sudo dpkg --install dolby-atmos-conversion-tool-2.X.X.xxxxxxx-Linux.deb (where xxxxxxx is the build number)

Note: There are two dashes before the word install.
b) If prompted with a warning that the package cannot be authenticated unless you accept the install

without verification, execute y for yes.

Results
Each Dolby Atmos Conversion Tool package component is installed on your computer, at the noted location:

• Dolby Atmos Conversion Tool command-line application (cmdline_atmos_conversion_tool): /usr/bin
• Dolby Atmos Conversion Tool documentation: /usr/share/doc/dolby-atmos-conversion-tool

2.4.2 Uninstalling the Dolby Atmos Conversion Tool Debian package
You can uninstall the Dolby Atmos Conversion Tool Debian package that was previously installed on a Linux
system (such as Ubuntu Xenial Xerus).

Procedure

Execute this command line:

sudo dpkg -r dolby-atmos-conversion-tool

2.4.3 Installing the Dolby Atmos Conversion Tool package on Mac
You can install the Dolby Atmos Conversion Tool package on a Mac system qualified by Dolby.

About this task
During installation, previous versions of the Dolby Atmos Conversion Tool are uninstalled.

Procedure

1. Start the installer by double-clicking the Dolby Atmos Conversion Tool installer package
DolbyAtmosConversionTool_2.X.X_xxxxxxx_Mac.pkg (where xxxxxxx is the build number).

2. Follow the on-screen instructions.

Installing the Dolby Atmos Conversion Tool package
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Results
Each supported Dolby Atmos Conversion Tool package component is installed on your computer at the
locations listed here:

• Dolby Atmos Conversion Tool: /Applications/Dolby/Dolby Atmos Conversion Tool
• Dolby Atmos Conversion Tool command-line application (cmdline_atmos_conversion_tool): /Applications/Dolby/

Dolby Atmos Conversion Tool
• Dolby Atmos Conversion Tool documentation: /Applications/Dolby/Dolby Atmos Conversion Tool

2.4.4 Uninstalling the Conversion Tool package on Mac
If necessary, you can uninstall the Dolby Atmos Conversion Tool package on Mac by deleting the folder that
contains the application and other package contents. Alternatively, you can delete just the tool application
or cmdline_atmos_conversion_tool Unix executable.

About this task
Uninstalling the Dolby Atmos Conversion Tool folder deletes these items:

• Dolby Atmos Conversion Tool application file
• cmdline_atmos_conversion_tool Unix executable
• All Conversion Tool documentation

Procedure

1. To uninstall the package:

a) Navigate to /Applications/Dolby.
b) Perform one of these steps:

• Right-click on the Dolby Atmos Conversion Tool folder, and choose Move to Trash.
• Drag the Dolby Atmos Conversion Tool folder to the trash.

2. To uninstall the tool application or command-line executable:

a) Navigate to /Applications/Dolby/Dolby Atmos Conversion Tool.
b) Perform one of these steps:

• Right-click on the Dolby Atmos Conversion Tool application file (or cmdline_atmos_conversion_tool Unix
executable file) folder, and choose Move to Trash.

• Drag the file to the trash.

2.4.5 Installing the Dolby Atmos Conversion Tool package on Windows
You can install the Dolby Atmos Conversion Tool package on a Windows system qualified by Dolby.

Procedure

1. Start the installer by double-clicking the Dolby Atmos Conversion Tool installer package
DolbyAtmosConversionTool_2.X.X_xxxxxxx_Win64.msi (where xxxxxxx is the build number).

Note: If prompted to uninstall an earlier version, close the message window, uninstall the older
version, and then start the installer again.

2. Follow the on-screen instructions.

Results
Each supported Dolby Atmos Conversion Tool package component is installed on your computer at the
locations listed here:

• Dolby Atmos Conversion Tool: C:\Program Files\Dolby\Dolby Atmos Conversion Tool

Uninstalling the Conversion Tool package on Mac
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• Dolby Atmos Conversion Tool command-line application (cmdline_atmos_conversion_tool): C:\Program Files
\Dolby\Dolby Atmos Conversion Tool

• Dolby Atmos Conversion Tool documentation: C:\Program Files\Dolby\Dolby Atmos Conversion Tool

2.4.6 Uninstalling the Conversion Tool on Windows
If needed, you can uninstall the Conversion Tool from your Windows computer.

Procedure

1. Navigate to Control Panel > Programs > Programs and Features.

2. Highlight Dolby Atmos Conversion Tool.
3. Click the Uninstall button.

4. Follow the on-screen instructions.

2.5 Launching the Dolby Atmos Conversion Tool
After the Dolby Atmos Conversion Tool software is installed, you can launch the tool.

Procedure

1. Locate the Dolby Atmos Conversion Tool application name or icon:

Figure 6: Dolby Atmos Conversion Tool icon

• Mac: The Dolby Atmos Conversion Tool application is in the Applications/Dolby/Dolby Atmos Conversion Tool
folder.

• Windows: The Dolby Atmos Conversion Tool application is in the C:\Program Files\Dolby\Dolby Atmos
Conversion Tool folder.

2. Double-click the Dolby Atmos Conversion Tool application name, or click the icon in the dock (Mac only).

Results
The Dolby Atmos Conversion Tool home window displays.

Figure 7: Dolby Atmos Conversion Tool home window

Installing the Dolby Atmos Conversion Tool package
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2.6 Quitting the Dolby Atmos Conversion Tool application
When the Dolby Atmos Conversion Tool application is open, you can quit the application from the home,
Conversion, or Composition window.

About this task

The commands and icons for quitting the application are not available when a dialog is open.

How the tool responds to the quit command is dependent on the current window, or window status:

• When quitting from the home window or Conversion window, or from the Composition window when
there are no clips on the timeline, the application closes immediately.

• When quitting from the Composition window and there are clips on the timeline, you are prompted with
a message noting that all information on the timeline will be lost. You can choose to proceed and close
the application, or cancel to return to the Composition window.

Procedure

• On Mac, perform one of these steps:

• Choose Dolby Atmos Conversion Tool > Quit.
• Click the quit application circle in the application window.
• Press Command+Q.

• On Windows, perform one of these steps:

• Choose Dolby Atmos Conversion Tool > Quit.
• Click the quit application circle in the application window.
• Press Control+Q.

2.7 Accessing operation log information
You can access log information that can be of value when debugging or reporting issues.

About this task
With v2.0, the location of the folder that contains the log files has changed:

• v2.0 folder:

• Mac: ~/Library/Logs/Dolby/Atmos Conversion Tool
• Windows: C:\ProgramData\Dolby\Atmos Conversion Tool\logs

• v1.9 folder:

• Mac: ~/Library/Logs/Dolby Laboratories/Atmos Conversion Tool/
• Windows: C:\ProgramData\Dolby Laboratories\Atmos Conversion Tool\logs

Procedure

Perform one of these steps:

• On systems with the Dolby Atmos Conversion Tool, access an atmos_conversion_tool.log file that is
automatically archived to your drive:

Note: Each log file name includes the date the file was created (for example,
atmos_conversion_tool.2018-11-05.log).

• On Mac:

1. Press Command+Shift+G.

Quitting the Dolby Atmos Conversion Tool application
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2. In the Go to the folder: field, enter the path ~/Library/Logs/Dolby/Atmos Conversion Tool, and then
click Go.

3. Double-click the Atmos Conversion Tool folder.
• On Windows: Navigate to the C:\ProgramData\Dolby\Atmos Conversion Tool\logs folder.

• When using a command-line program, copy the relevant lines of information in the command-line
program window.

All informational log messages are written directly to standard output, and all error log messages are
written directly to standard error. Both streams will appear in the shell terminal as console output.

Installing the Dolby Atmos Conversion Tool package
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3 

Dolby Atmos Conversion Tool UI
The Dolby Atmos Conversion Tool UI provides windows for performing conversion and composition
tasks.

• Home window UI
• Conversion window UI
• Composition window UI
• Progress windows
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3.1 Home window UI
The home window includes buttons for starting a new conversion or composition.

Figure 8: Dolby Atmos Conversion Tool home window

New conversion button
Click this button to start a new conversion. This action opens the default Conversion window, where
you can import a master file, and then convert the format, frame rate, FFOA, or primary language (IMF
IAB only) of a master file.

New composition button
Click this button to start a new composition. This action opens the default Composition window. In the
new composition, you can edit, join, or convert one or more master files.

3.2 Conversion window UI
The Conversion window provides a work area to import a master and then convert the format, frame rate,
FFOA, or primary language (IMF IAB only) of the master.

3.2.1 Default conversion window
The Conversion window is empty by default. After you import a master, it provides the controls and displays
for performing a conversion.

Dolby Atmos Conversion Tool UI
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Figure 9: Default conversion window , with no master file loaded

Drop master file here or browse area
In the default Conversion window, this is the large, empty area that has a dotted outline. You can import a
Dolby Atmos master by dropping it into this area or by clicking in this area to browse to the master and open
it. Optionally, you can use the File > Import Master File menu command, which is available when the
Conversion window is open, to browse to a master and open it.

Output section

In the default Conversion window, the controls and displays in this section are grayed out and unavailable.
The controls and displays become available when a master is imported.

3.2.2 Conversion window with an imported master
After a master has been imported into the Conversion window, the window provides controls and displays
for converting the master, or performing other conversion tasks.

Figure 10: Example of a conversion window with an imported master

Source master file section

After a master has been imported, the window provides information about the master.

Conversion window with an imported master
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The left side of the window displays the source master name, along with the format, sample rate, and frame
rate. The display of the frame rate is dependent on the source master format:

• .atmos (or .damf), .wav (Audio Definition Model (ADM) Broadcast Wave Format (BWF)), .Material Exchange
Format (MXF) (Digital Cinema Package (DCP) IAB), or .mxf (IMF IAB)

Figure 11: Source master file section for master files other than .rpl

The frame rate is included in the window. Valid frame-rate values are all frame rates supported by the
source master. If the input .atmos (or .damf), .wav (ADM BWF), or .mxf (IMF IAB) file has an fps value, it will be
automatically loaded. If the .damf does not have a specified frame rate, the field defaults to 23.976 fps.

• .rpl

Figure 12: Source master file section for an .rpl master file

After importing an .rpl into the Conversion window, the source drop-down menu displays under the file
name. By default, this menu sets the source frame rate. Changing this value also changes these timecode
values in the Output section: target frame rate, and output start, end, and duration.

The right side provides detailed information about the source master:

Dolby Atmos Conversion Tool UI
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Figure 13: Source master file, example of detailed information

• Path: This is the location of the master.
• Bit depth: This is the bit depth of the master.
• Duration: This is the duration of the master (from start to end), in timecode.
• Start time: This is the start time of the master, in timecode.
• FFOA (First frame of action): This is the FFOA for the master (if included), in timecode, or the not included

status. For timecode, this value is rounded, if it was on a non-frame boundary.
• Language: For a source .mxf (IMF IAB), this is the primary language for the master (if included).
• Channels: This is the number of mono channels that were defined when the master was originally

created or joined together. This includes the total number of mono channels for beds and objects.
• Objects: This is the number of mono objects that were defined in the Dolby Atmos Renderer input

configuration before the master was created.
• Beds: This is the number of beds that were defined when the master was originally created or joined

together.
• Bed configuration: For each bed that was defined when the master was originally created or joined

together, this assigns a number to the bed in sequential order, and provides the bed number and
respective width.

• Created with: This provides the name and version of the application that was used to create the master
(such as Dolby Atmos Renderer, Dolby Atmos Conversion Tool, or a third-party application).

Output section
This section provides settings for the conversion target master, dependent on the source master and
selected target format.

Figure 14: Output section example (conversion window)

File format
Use this drop-down menu to choose whether to convert the input source master to a Dolby Atmos
(.atmos) master set of files, .rpl cinema print master, .wav (ADM BWF) file, or .mxf (IMF IAB) file.

.atmos, ADM BWF .wav, and IMF IAB .mxf files can be ingested into supported Dolby Atmos encoding tools.

Conversion window with an imported master
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Frame rate

Valid values for this drop-down menu are all frame rates supported by the target master, in fps:

• If the input .atmos (or .damf), .wav (ADM BWF), or .mxf file has a frame rate value, it will be automatically
loaded.

• If the .damf does not have a specified frame rate, the field defaults to 23.976 fps.
• Cinema .rpl files use the last used frame rate (as stored in preferences). The target frame rate can

then be changed with this drop-down menu (or the source frame-rate drop-down menu). Valid
values are 24, 25, or 30 fps.

• For source, we let you choose the frame rate. The output frame rate uses the last used frame rate (as
stored in prefs)

Primary language
When converting to .mxf (IMF IAB) files, use this drop-down menu and field to choose a primary language.
The Conversion Tool supports setting the primary language to a common language. For a full list, see
Primary languages supported by the Conversion Tool .

There are two ways to change the language:

• Click on the Primary language drop-down menu, scroll to the desired language, and click (highlight)
a language.

• Click in the Primary language field, highlight the existing text (if any), type the first letters of the
desired language, scroll to the language, and then click (highlight) the language:

• The field is not character sensitive.
• You can enter uppercase or lowercase characters to discover a language. Pressing Escape returns

the last selected language.

Note:

The tool remembers the last primary language that was selected. For example, when you
change the output format from .mxf (IMF IAB) to another output format, or close the tool, the
primary language that was selected last will be displayed in the Output section, in the Primary
language field.

Add FFOA (in source FPS) switch and field

This field displays the FFOA in timecode, in the source frame rate, and lets you keep the value, change it,
or not include any FFOA in the target master. Enable the switch to keep or change the source value.
Disable the switch to not include an FFOA with the converted master.

When including an FFOA, the value must be the same as or later than the start of the master file, and
before the last frame of the file. When an invalid value is entered, the FFOA display in the Output
section turns red and reads Invalid FFOA.

If the source .atmos or .wav file has an FFOA value, it will be automatically loaded. Otherwise, the default
is the start time, in timecode, rounded to a valid frame.

Start
This display shows the start of the target master in timecode, based on the target frame rate.

End
This display shows the end of the target master, in timecode, based on the target frame rate.

FFOA
This display shows the FFOA value or status, based on the Add FFOA setting and target format. If the
Add FFOA switch is off, the status displays Not included, grayed out.

Duration
This display shows the duration of the target master in timecode, based on the target rate.

Dolby Atmos Conversion Tool UI
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Convert button

Press this button to begin the conversion process. This button is grayed out when a source file is loading
or a conversion is underway.

3.3 Composition window UI
The Composition window provides the UI for importing one or more masters as a clip, and then performing
composition tasks (such as editing a clip, joining clips, or converting a clip to another Dolby Atmos master
file format).

3.3.1 Default Composition window
The Composition window is empty by default. After you import a master file to the timeline, the window
provides the controls and displays for editing and converting that master, and any additional masters that
you import to the timeline.

Figure 15: Default composition window, with master files list hidden

Master files list

In the default Composition window, this list is closed and contains no master files.

You can click the MASTER FILES list reveal button to open the list, where you can then drop a master file to
later add to the timeline. Optionally, you can import a master file into the timeline, which automatically
adds it to the list.

Drop master files here or browse area
In the default Composition window, this is the large, empty area that has a dotted outline. It represents the
composition timeline.

You can import one or more Dolby Atmos master files by dropping the files from a drive into this area or by
clicking in the window to browse to the files. Each master is imported into the MASTER FILES list and
composition timeline (as a clip). Optionally, you can drop a file from the MASTER FILES list.

Note: To import an .xml (pmstitch) file into a composition, you must use the File > Open .xml
(pmstitch) command.

Output section

In the default Composition window, the controls and displays in this section are grayed out and
unavailable. The controls and displays become available when a clip is imported into the timeline.

Composition window UI
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3.3.2 Composition window with imported masters
The Composition window provides GUI controls for managing master files, displays, and conversion settings
for a composition. The window includes the MASTER FILES list, composition timeline, advanced metadata
section, composition section, and output section.

Figure 16: Composition window example, with multiple master files in the master files list and timeline

3.3.3 Master files list
The MASTER FILES list provides a bin where you can import master files into the list and composition
timeline simultaneously, or the list only (to later add to the timeline).

In the default Composition window, the list is hidden. When revealed in a new composition, the list is
empty.

Figure 17: Composition window, with master files list revealed and no master files

The MASTER FILES list provides these items to manage master files for a composition:

Master files list counter 

This blue circle with white text provides the number of master files that have been imported into the list.
In the default window, the count is 0.

Dolby Atmos Conversion Tool UI
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Reveal button 

This button reveals and hides the list. In the default window, the list is empty.

List
This is the area in the MASTER FILES section that has a dotted outline. You can import a master file into
the list by dragging the file into this area or by using the File menu. Alternatively, you can import a
Dolby Atmos master file into the timeline, which also adds it to the MASTER FILES list.

For a new composition, the list is empty.

Figure 18: Empty master files list, when revealed

After a file is imported, it displays in the list with the file name, format, frame rate, and FFOA. Each file in
the list is available for adding to the composition timeline as a clip.

Master files list
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Figure 19: Example of the master files list with multiple masters imported

You can click (select) a file in the list to see detailed information about the file, or to remove the file from
the list. When you click on a master file in the list, the file displays with an outline to show that is has
been selected.

• If the advanced metadata section is open, it displays detailed information about the selected
master.

Dolby Atmos Conversion Tool UI
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Figure 20: Advanced metadata section, with a master selected

• When a file is selected, you can right-click on the file, and select Remove master file to remove the
master from the list. Alternatively, you can choose Edit > Remove Master File.

Figure 21: Removing a master file from the list

3.3.4 Timeline
The timeline provides the area where you import one or more masters as clips for performing composition
tasks.

Clips in the timeline

Each clip imported into the timeline includes these elements:

• Clip master name: The name of the master associated with the clip always displays above the clip.

Timeline
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Figure 22: Clip in the timeline, unselected

• Selected clip: When you click on a clip, it updates with a blue outline.

Figure 23: Clip in the timeline, selected

You can then use menu commands or right-click commands to perform composition tasks (such as Trim,
Split, or Remove timeline). If you have edited the clip, you can also use the Reset to original right-click
command to return the clip to its original state.

The outline also includes handles for trimming the clip.

• Clip with subframe boundaries

When a file that starts or ends on subframe boundaries is imported into the Composition window, it is
extended with silence to the next frame boundary in either direction, so that no underlying content is
trimmed. The clip displays a horizontal green line to denote the extension.

Figure 24: Clip with extended silence to the next frame boundary

Dolby Atmos Conversion Tool UI

Dolby Atmos Conversion Tool v2.0 Software Guide 30

30 April 2020



• Start, end, and duration of a clip (the master associated with the clip), relative to the start of the clip: This
metadata displays when you hover over the clip in the timeline (or click on the clip in the Composition
section).

Figure 25: Timecode locations, relative to a clip (shown in the timeline) and composition (shown in the
composition section)

Concurrently, the Output section includes the timecode location relative to the composition in the
Composition section. The two timecodes and respective timecode lines, along with a cursor, display
when you hover over the timeline. You can move the cursor to the left or right to display other timecode
locations.

Note: The timecode in the timeline is in the source frame rate; the timecode in the Output
section is in the target frame rate.

Bars for inserting silence

Before and after each clip, there are empty bars for inserting silence to create a silence clip. You can edit
silence clips.

Empty silence bar

There is no silence at this location.

Ready to edit silence bar
When you hover over the empty silence bar, the bar turns green and displays a + symbol. You can click
on the bar and then set the amount of silence.

Timeline
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Silence clip

A silence clip displays as a green moiré pattern. When you hover over a silence clip, it displays the length
of the silence.

Note: An inserted silence clip also displays in the composition bar.

You can right-click on a silence clip to edit the length or remove the silence from the timeline.

When a silence clip is selected and the advanced metadata section is shown, the advanced metadata
section shows the length of the clip.

View controls

Zoom slider
Use this slider to change how clips display in the timeline.

Dolby Atmos Conversion Tool UI
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• To zoom in on the clips in the timeline, click on the zoom slidebar and drag it to the right (toward the
+ symbol).

• To zoom out on the clips in the timeline, click on the zoom slidebar and drag it to left (toward the -
symbol).

• To zoom so that all the clips fit in the visible timeline, click on the zoom slidebar and drag it all the
way to the left.

Clips scroll bar
Use this scroll bar to scroll left or right through the clips in the timeline. This scroll bar displays when
you have one or more clips that do not fit in the timeline viewable area (for example, after zooming in on
a clip, or after importing multiple masters as clips).

Alternatively, you can click anywhere in the timeline above or below the clips, and scroll to the left or
right.

3.3.5 Advanced metadata section
This section of the Composition window displays detailed information (advanced metadata) of a master or
clip, or the length of a silence clip.

The advanced metadata section provide this information, dependent on the current selection:

• When a master is selected in the MASTER FILES list, this section displays detailed master file
information.

• When a clip associated with a master is selected in the timeline, or in the Composition section, this
section displays information for the clip and the associated master file.

• When a silence clip is selected, this section displays the length of the silence.

Show/hide advanced metadata icon 

Click on the advanced metadata icon to show (or hide) the advanced metadata section, or click the X icon to
close the section. When the metadata section is open, the icon is blue.

When no master or clip is selected, the section contains no metadata, and provides a tip to select a clip or
master to see its details. When a clip or master is selected, the section displays the relevant metadata.

Advanced metadata section
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Master file information
When a master is selected in the MASTER FILES list, or a clip is selected in the timeline or Composition
section, the display provides the master file name and this master file information:

Figure 26: Advanced metadata section, with a master selected

• Path: This is the location of the master.
• Type: This is the format of the Dolby Atmos master.
• Frame rate: This is the frame rate of the master, in fps.
• Sample rate: This is the sample rate of the master, in kHz.
• Bit depth: This is the bit depth of the master.
• Duration: This is the duration of the master (from start to end), in timecode.
• Start time: This is the start time of the master, in timecode.
• FFOA. This is the FFOA for the master (if included), in timecode, or the not included status. For timecode,

this value is rounded, if it was on a non-frame boundary.
• Language: For a source .mxf (IMF IAB) file, this is the primary language for the master (if included).
• Channels: This is the number of mono channels that were defined when the master was originally

created or joined together. This includes the total number of mono channels for beds and objects.
• Objects: This is the number of mono objects that were defined in the Dolby Atmos Renderer input

configuration before the master was created.
• Beds: This is the number of beds that were defined when the master was originally created or joined

together.
• Bed configuration: For each bed that was defined when the master was originally created or joined

together, this assigns a number to the bed in sequential order, and provides the bed number and
respective width.

• Created with: This provides the name and version of the application that was used to create the master
(such as Dolby Atmos Renderer, Dolby Atmos Conversion Tool, or a third-party application).

Dolby Atmos Conversion Tool UI
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Clip only information
When a clip associated with a master is selected in the timeline, or in the Composition section, the display
provides clip information. When a clip is trimmed, the timecode updates.

Figure 27: Advanced metadata section, with a clip selected

• Clip start: This is the start time of the clip, in timecode.
• Clip end: This is the end time of the clip, in timecode.
• Clip duration: This is the length of the clip, in timecode.

Silence clip length
When a silence clip is selected in the timeline, the display provides the length of the silence, in timecode.
When a length of the silence clip is changed, the timecode updates.

Figure 28: Advanced metadata section, with a silence clip selected

Advanced metadata section
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Advanced metadata scroll bar
This scroll bar displays when any advanced metadata is not visible in the section (for example, when a
master has numerous beds, or you have a clip selected). Use this scroll bar to scroll down (or up) to see
information.

Figure 29: Scroll bar in the advanced metadata section

3.3.6 Composition section
The Composition section provides controls for setting the composition start time and FFOA. Additionally,
the section provides a bar for selecting a clip and displaying clip metadata.

Figure 30: Composition section in the composition window

All timecode values in the Composition section are in the source frame rate, in fps.

Composition bar and clips
The Composition bar lets you view the entire composition regardless of the zoom level in the timeline.
The bar provides a representation of each clip.

Dolby Atmos Conversion Tool UI
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Figure 31: Example of composition bar with four clips

Click a clip in the bar to select the clip and bring the clip into view in the timeline. If the advanced
metadata section is open, it will display metadata for the clip and the associated master.

Additionally, you can click (or hover over) a clip to display the clip start, end, and duration timecode,
relative to the composition.

Start field
This field displays the start time that will be used for the composition when it is converted into a new
master. The start time is in timecode, in the source frame rate. You can keep the value as is, or update it.
By default, the value is at zero.

When this value is changed, the Duration and End displays in the Composition section update
accordingly. Additionally, related displays in the Output sections update.

If the start value results in an invalid FFOA (as entered in the Add FFOA field), the FFOA in the Output
reads FFOA invalid, the start, end, and duration times in the Output section are not calculated, and the
composition cannot be converted. If the start value results in an invalid start, end, or duration value (for
example, when crossing the midnight boundary), these values display in the Output section in red.

Note: The start, end, FFOA, and duration may be different than what is shown in the
Composition section if you are converting to a different frame rate.

Add FFOA switch and field

This field displays the FFOA that will be used for the composition when it is converted into a new
master. The FFOA is in timecode, in the source frame rate. You can keep the value, change it, or not
include an FFOA in the target master. By default, the value is at zero.

Enable the switch to keep or change the source value. Disable the switch to not include an FFOA with
the converted master.

When including an FFOA, the value must be the same as or later than the composition start time, and
before the last frame of the file. When an invalid value is entered, the FFOA display in the Output
section turns red and reads Invalid FFOA.

End
This display shows the end of the target master, in timecode, in the source frame rate, and is based on
the source start time.

Duration
This display shows the duration of the target master in timecode, in the source frame rate, and is based
on the source start time.

3.3.7 Output section
The Composition section provides controls for setting the format, frame rate, primary master, and primary
language (IMF IAB only) of the target master. Additionally, the section displays the start, end, FFOA, and
duration of the target master, in timecode, in the target fps.

Figure 32: Output section (composition window)

Output section

Dolby Atmos Conversion Tool v2.0 Software Guide 37

30 April 2020



Output drop-down menus

File format
Use this menu to choose whether to convert the composition to a Dolby Atmos (.atmos) master set of
files, .rpl cinema print master, .wav (ADM BWF) file, or .mxf (IMF IAB) file.

Frame rate

Valid values for this menu are all frame rates supported by the target master, in fps.

Primary master
In this menu, choose which master associated with a clip should be considered the primary master for
the converted master.

The primary master specifies the program-level metadata that is used for the target master. sThis
includes trim and downmix metadata (as written by the Dolby Atmos Renderer) and additional
Dolby Atmos and Dolby Digital Plus parameters. The Dolby Atmos and Dolby Digital Plus parameters
typically have default values, unless they have been manually edited within the .dbmd file within
an .atmos or .rpl package.

Program-level metadata specified by the primary master is applied for all supported target master
formats: .atmos, .mxf (IMF IAB), .rpl, and .wav (ADM BWF).

Primary language
When converting to .mxf (IMF IAB), use this drop-down menu and field to choose a primary language. The
Conversion Tool supports setting the primary language to a common language. For a full list, see
Primary languages supported by the Conversion Tool .

There are two ways to change the language:

• Click on the Primary language drop-down menu, scroll to the desired language, and click (highlight)
a language.

• Click in the Primary language field, highlight the existing text (if any), type the first letters of the
desired language, scroll to the language, and then click (highlight) the language:

• The field is not character sensitive.
• You can enter uppercase or lowercase characters to discover a language. Pressing Escape returns

the last selected language.

Note:

The tool remembers the last primary language that was selected. For example, when you
change the output format from .mxf (IMF IAB) to another output format, or close the tool, the
primary language that was selected last will be displayed in the Output section, in the Primary
language field.

Output displays

This section provides the start, end, FFOA, and duration of the converted target master, in timecode, in the
target frame rate.

Note: The start, end, FFOA, and duration of the converted files may be different than what is shown
in the Composition section if you are converting to a different frame rate. You can import your
converted file after the conversion to verify these values in the advanced metadata window in the
Composition window, or information section of the Conversion window.

Start
This display shows the start of the target master, as set in the Composition section, and based on the
target frame rate.

Dolby Atmos Conversion Tool UI
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End
This display shows the end of the target master, relative to the start time set in the Composition
section, and based on the target frame rate.

FFOA
This display shows the first frame of action value or status, in the target frame rate.

It is based on the Add FFOA switch and setting in the Composition section. If the Add FFOA switch is off,
the status displays Not included, grayed out. If the switch is on, and the set value is invalid, this display
reads Invalid FFOA, in red.

Duration
This display shows the duration of the target master, relative to the start time set in the Composition
section, and based on the target frame rate.

Convert button

Press this button to begin the conversion process.

3.4 Progress windows
When importing a master file, or after pressing the Convert button to perform a conversion, a progress
window displays.

Progress window when importing a master file to the conversion window or composition window
timeline

Loading message and progress bar
This message and display bar, located in the middle of the window, show the progress of the import.

Figure 33: Importing a master example

Cancel button (conversion window and composition timeline)
Click this button to stop the import.

Progress bar for importing a master file into the master files list

File being loaded message and progress bar
The file name being loaded and display bar, located at the top of the MASTER FILES list, show the
progress of the import.

X button
Click this button to stop the import.

Progress windows
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Progress window for a conversion

Converting message and progress bar
This message and display bar, located in the middle of the window, show the progress of the
conversion.

Cancel button
Click this button to stop the conversion.

File exported successfully message and button
When the conversion completes, the File exported successfully message displays. The available button
and result of pressing the button is dependent on the current workflow window:

• If performing a conversion in the Conversion window, click OK. This returns you to the Conversion
window and the most recent master and conversion settings.

• If performing a conversion in the Composition window, click Return to timeline. This returns you to
the Composition window, and the most recent clip and composition settings (as well as the most
recent MASTER FILES list).

Dolby Atmos Conversion Tool UI
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4 

Dolby Atmos Conversion Tool application
menus
The Conversion Tool provides a menu and submenu structure for access to commands for common
conversion and composition workflows.

• Dolby Atmos Conversion Tool menu (Mac only)
• Home window menus
• Conversion window menus
• Composition window menus
• Keyboard shortcuts
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4.1 Dolby Atmos Conversion Tool menu (Mac only)
On Mac, the Conversion Tool provides standard application menus for checking the version number and
performing basic window and application management. This menu is available in the home window,
Conversion window, and Composition window.

Dolby Atmos Conversion Tools menu

Most of the menus are common to other application name menus for Mac.

Figure 34: Dolby Atmos Conversion Tool menu

About <application name>
This menu provides this information:

• Application name: Dolby Atmos Conversion Tool
• Software version
• Dolby copyright and trademark information

Hide <application name>
Use this command to hide the current application.

Keyboard shortcut: Command + H (Mac) or Control + H (Windows).

Hide others and show all
Use these commands to show or hide all applications, excluding the current application.

Keyboard shortcut: Command + Option + H (Mac) or Control + Alt + H (Windows).

Quit <application name>
Use this command to close the current Conversion Tool window and quit the application.

Keyboard shortcut: Command + Q (Mac) or Control + Q (Windows).

4.2 Home window menus
The home window provides the menus for creating a new conversion or composition.

4.2.1 File menus (home window)
The File menu in the home window provides the menus for creating a new conversion or composition.

Figure 35: Home window file menu

Dolby Atmos Conversion Tool application menus
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New conversion
The New Conversion menu command opens the default Conversion window, where you can import a
master for converting. Optionally, you can click the New Conversion button in the home window.

Keyboard shortcut: Command + N (Mac) or Control + N (Windows).

New composition
The New Composition menu command opens the default Composition window, where you can import one
or more masters for editing or joining, or one master for converting. Optionally, you can click the New
Composition button in the main window.

Keyboard shortcut: Command + Shift + N (Mac) or Control + Shift + N (Windows).

Note: To import an .xml (pmstitch) file into a composition, you must use the File > Open .xml
(pmstitch) command.

4.3 Conversion window menus
When working on a conversion in the Conversion window, the Conversion Tool provides a menu and
submenu structure for access to commands for importing a master and performing other common
conversion tasks.

4.3.1 File menus (conversion window)
The Conversion window provides menu commands to import a Dolby Atmos master to perform a
conversion, or close the Conversion window and return to the home window.

Import master file
This menu command lets you browse to a supported master file and open it in the Conversion window,
where you can perform a conversion. Optionally, you can drop a master in the Conversion window timeline,
or click in the work area to browse to a master.

Keyboard shortcut: Command + I (Mac) or Control + I (Windows).

Close (conversion window)
This menu command immediately closes the Conversion window and returns the application to the home
window.

Keyboard shortcut: Command + W (Mac) or Control + W (Windows).

4.3.2 Edit menus (conversion window)
This menu provides commands for copying and pasting timecode to or from the FFOA field of a master
loaded in the Conversion window.

New conversion
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Copy
Use this command to copy the FFOA of a master so that you can use the value with another conversion
or for your records.

To copy the FFOA from a master, the master must be loaded in the tool and have a defined FFOA, the
Add FFOA switch is enabled, and you have highlighted the value.

Alternatively, press Command + C (Mac) or Control + C (Windows).

Paste
Use this command to paste a new FFOA value into a master before running a conversion.

To paste the FFOA into a master, the master must be loaded in the tool, the Add FFOA switch is enabled,
and you have highlighted the existing value. Additionally, the FFOA must be the same as or later than
the offset in the file, and before the last frame of the file.

Alternatively, press Command + V (Mac) or Control + V (Windows).

4.4 Composition window menus
When working on a composition in the Composition window, the Conversion Tool provides a menu and
submenu structure for access to commands for importing one or more masters, and performing other
common composition tasks.

4.4.1 File menus (composition window)
The Composition window provides menu commands to import one or more Dolby Atmos master files, or
close the Composition window and return to the home window.

New (composition window)
This menu command closes the current composition and returns you the default Composition window, with
an empty MASTER FILES list and timeline.

Keyboard shortcut: Command + N (Mac) or Control + N (Windows).

When you choose this command and there are one or more clips in the timeline, you will be prompted with a
message that all information on the timeline will be lost, and asking if you are sure you want to proceed.
Click Proceed to close the window. Click Cancel to remain in the Composition window.

Open .xml (pmstitch)
This menu command imports an.xml (pmstitch) file into the MASTER FILES list and the timeline. Each master
and silence clip in the file is added to the timeline as an individual clip. Existing masters in the Composition
window are removed.

Keyboard shortcut: Command + O (Mac) or Control + O (Windows).
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Import Master File (composition window)
This menu command lets you browse to a supported master file and add to the MASTER FILES list in the
Composition window, where it can subsequently be added to the composition timeline as a clip.

Keyboard shortcut: Command + I (Mac) or Control + I (Windows).

Close (composition window)
This menu command closes the Composition window and returns the application to the home window.

Keyboard shortcut: Command + W (Mac) or Control + W (Windows).

When you choose this command and there are one or more clips on the timeline, you will be prompted with
a message that all information on the timeline will be lost and asking if you are sure you want to proceed.
Click Proceed to close the window. Click Cancel to remain in the Composition window.

4.4.2 Edit menus (composition window)
This menu provides commands for copying and pasting timecode to or from the FFOA field or start time of a
composition, plus a command to remove a master or clip.

Copy
Use this command to copy the FFOA or start time of a composition so that you can use the value with
another entry or for your records.

To copy the FFOA or start time, there must be at least one master clip in the timeline and you have
highlighted the timecode value you want to copy. Additionally, for the FFOA, the primary master in the
timeline must have a defined FFOA, and the Add FFOA switch is enabled.

Alternatively, press Command + C (Mac) or Control + C (Windows).

Paste
Use this command to paste a new FFOA or start value into a composition before running a composition
conversion.

To paste the FFOA or start time into a composition, there must be at least one master clip in the
timeline, and you must have highlighted the target timecode. Additionally, for an FFOA, the Add FFOA
switch is enabled, and the FFOA must be the same as or later than the offset in the composition.

The FFOA must be the same as or later than the offset in the .atmos or .wav file, and before the last frame
of the file

Alternatively, press Command + V (Mac) or Control + V (Windows).

Remove, remove master file, or remove from timeline
Use this command to remove the currently selected master in the MASTER FILES list or clip in the
timeline, respectively. When no master or clip is selected, this command is grayed out and displays as
Remove.
When attempting to remove a master from the list that has any associated clips in the timeline, you will
be prompted with a message that removing the master will also remove the clips. Click Remove master
to remove the master, or click Cancel to return to the composition with no changes.

Alternatively, press Delete (Mac US QWERTY) or Backspace (Mac International QWERTY, or Windows).

Import Master File (composition window)
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4.4.3 Timeline menu
The timeline in the Composition window provides controls for editing a clip.

Trim
Use this command to trim the start and end of a selected clip in the timeline. The command opens the
Trim window, where you can set the start and end times.

Alternatively, press Command + T (Mac) or Control + T (Windows).

The Trim command is available when a clip is selected.

Split
Use this command to split a selected clip into two clips. The command opens the Split window, where
you can set the location of the split.

Alternatively, press Command + E (Mac) or Control + E (Windows).

The Split command is available when a clip is selected.

Add Silence
This menu provides access to the commands for inserting silence before or after a selected clip in the
timeline:

• Before Selected Clip: This command opens the Insert silence window, where you can set the
amount of silence to add before the selected clip.

• After Selected Clip: This command opens the Insert silence window, where you can set the amount
of silence to add after the selected clip.

The Add Silence command is available when a clip is selected.

Add Master File to Timeline
Use this command to add a master selected in the MASTER FILES list to the timeline as a clip, so that
you can work on it. If the timeline has one or more clips in it, this operation places the master after the
last master in the timeline.

Alternatively, press Command + J (Mac) or Control + J (Windows).

Clear Timeline
Use this command to clear all of the clips in the composition timeline. This command opens the Clear
Timeline window, where you can choose to proceed with the operation, or cancel it.

4.4.4 View menu
The View menu provides commands for setting how clips and clip metadata display in the composition
timeline and Composition (in source FPS) section. Additionally, you can display detailed (advanced)
metadata for a clip or master, or the length of a silence clip.

Dolby Atmos Conversion Tool application menus
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Show Advanced Metadata
Use this command to display the advanced metadata of a master or clip, or the length of a silence clip.
This command opens the advanced metadata section (to the right of the composition timeline).

Alternatively, press Command + Shift + P (Mac) or Control + Shift + P (Windows).

Zoom In
This command makes the size of the clips in the timeline larger, by zooming in on the clips.

Alternatively, you can press Command + the plus symbol (Mac) or Control + the plus symbol (Windows).

Zoom Out
This command makes the size of the clips in the timeline smaller, by zooming out on the clips.

Alternatively, you can press Command + the minus symbol (Mac) or Control + the minus symbol
(Windows).

Zoom to Fit
This command zooms in on the clips in the timeline, so that all of the clips display in the visible timeline.

Alternatively, you can press Command + 0 (Mac) or Control + 0 (Windows).

4.5 Keyboard shortcuts
The Dolby Atmos Conversion Tool UI includes keyboard shortcuts to choose various Conversion Tool menus,
as well as shortcuts to navigate through pages for preferences.

Common menu shortcuts

The Dolby Atmos Conversion Tool menu is available in the home window, Conversion window, and
Composition window.

Table 1: Dolby Atmos Conversion Tool menu shortcuts

Menu Mac keyboard shortcut Windows keyboard shortcut

Hide <application> Command + H Control + H

Hide others Command + Option + H Control + Alt + H

Quit <application> Command + Q Control + Q

Home window shortcuts

Table 2: File menu shortcuts in the home window

Menu Mac keyboard shortcut Windows keyboard shortcut

New conversion Command + N Control + N

New composition Command + Option + N Control + Alt + N

Keyboard shortcuts
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Conversion window shortcuts

Table 3: File menu shortcuts in the conversion window

Menu Mac keyboard shortcut Windows keyboard shortcut

Import master file Command + I Control + I

Close Command + W Control + W

Table 4: Edit menu shortcuts in the conversion window

Menu Mac keyboard shortcut Windows keyboard shortcut

Copy Command + C Control + C

Paste Command + V Control + V

Composition window menu shortcuts

Table 5: File menu shortcuts in the composition window

Menu Mac keyboard shortcut Windows keyboard shortcut

New Command + N Control + N

Open .xml (pmstitch) Command + O Control + O

Import master file Command + I Control + I

Close Command + W Control + W

Table 6: Edit menu shortcuts in the composition window

Menu Mac keyboard shortcut Windows keyboard shortcut

Copy Command + C Control + C

Paste Command + V Control + V

Remove Not applicable Not applicable

Remove master file (when a master is
selected in the MASTER FILES list)

Delete (US QWERTY), Backspace
(International QWERTY)

Delete

Remove from timeline (when a clip is
selected in the timeline)

Delete (US QWERTY), Backspace
(International QWERTY)

Delete

Table 7: Timeline menu shortcuts in the composition window

Menu Mac keyboard shortcut Windows keyboard shortcut

Trim Command + T Control + T

Split Command + E Control + E

Add master file to timeline Command + J Control + J

Table 8: View menu shortcuts in the composition window

Menu Mac keyboard shortcut Windows keyboard shortcut

Show advanced metadata Command + Shift + P Control + Shift + P

Zoom in Command + plus sign Control + plus sign
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Table 8: View menu shortcuts in the composition window (continued)

Menu Mac keyboard shortcut Windows keyboard shortcut

Zoom out Command + minus sign Control + minus sign

Zoom to fit Command + 0 Control + 0

Keyboard shortcuts
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5 

Dolby Atmos Conversion Tool overview of
workflows and considerations
The Dolby Atmos Conversion Tool lets you convert one Dolby Atmos master file format to another, edit
or join masters as a composition, or perform other tool operations (like applying frame-rate
conversion to a Dolby Atmos master file).

• New conversion and new composition workflows
• Supported Dolby Atmos master file formats
• Sample rate considerations
• Considerations when setting the frame rate
• Considerations when setting the FFOA
• Hard disk space requirements
• Persistent application data

Dolby Atmos Conversion Tool overview of workflows and considerations
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5.1 New conversion and new composition workflows
The Conversion Tool application supports two primary types of workflows (or modes) when using the
Conversion Tool application on supported Mac and Windows systems.

Note: The Conversion Tool command-line application and options let you perform tool operations
from a dedicated command-line program on Linux, Mac, and Windows operating systems.

New conversion

Create a new conversion to convert the format, frame rate, FFOA, or primary language (IMF IAB only) of a
master.

You perform conversion work in the Conversion window.

Figure 36: Example of conversion window, with an imported master file

You can perform changes to the format, frame rate, FFOA, or primary language (IMF IAB only) simultaneously
or separately.

The length of a master file opened in the Conversion window is not altered if the master file starts and ends
on non-frame boundaries.

New composition

Create a new composition to edit one or more masters (for example, to trim a master or insert silence), join
multiple masters (with or without making edits), or convert the format, frame rate, FFOA, or primary
language (IMF IAB only) of a master.

You perform composition work in the Composition window.

New conversion and new composition workflows
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Figure 37: Example of a composition, with multiple master files in the master files list and composition
timeline

You can perform changes to the format, start time, frame rate, FFOA, or primary language (IMF IAB only)
simultaneously or separately.

When a file that starts or ends on subframe boundaries is imported into the Composition window, it is
extended with silence to the next frame boundary in either direction, so that no underlying content is
trimmed. The clip displays a horizontal green line to denote the extension.

Figure 38: Clip with extended silence to the next frame boundary

Single master conversions

You can convert a single master from one Dolby Atmos format to another (or do other tool operations) using
either a new conversion or new composition.

Perform a new conversion (in the Conversion window):

• When you do not need to change the length of the master, or change the start time
• When you want to preserve source start and end timecodes that are on non-frame boundaries

Perform a new composition (in the Composition window):

• When you want to change the length of the master (for example, by trimming or inserting silence at the
start of the master)

• When you want to change the start time of the master
• When it is acceptable for the source start and end times to extend to the nearest frame boundaries, if on

a subframe

Related information
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Dolby Atmos Conversion Tool overview of workflows and considerations on page 58
Editing, joining, or converting Dolby Atmos clips in a composition on page 63

5.2 Supported Dolby Atmos master file formats
The Conversion Tool supports working with various Dolby Atmos file formats as input source files and
output target files. This includes performing the conversion with a new conversion or new composition in
the tool application, or using command-line options.

Table 9: Conversion Tool source input and target output files

Input format Output format

.atmos .mxf (IMF IAB) .rpl .wav (ADM BWF)

.atmos (or .damf) [a] Yes Yes Yes Yes

.mxf (DCP IAB) Yes Yes Yes Yes

.mxf (IMF IAB) Yes [b] Yes Yes [b] Yes [b]

.rpl [a] Yes Yes Yes Yes

.wav (ADM BWF) Yes Yes Yes Yes

.xml (pmstitch) [c] Yes Yes Yes Yes

[a] .atmos, .damf, and .rpl file formats can include a .dbmd metadata file when converting to .atmos, .mxf (IMF IAB), .wav (ADM BWF). .atmos files
created with Renderer v3.2.x and later automatically include a.dbmd file.

[b] Because IMF IAB positional metadata is quantized to eight events per frame, an IMF IAB is considered a mezzanine rather than a
master. Converting from IMF IAB to another format will keep metadata events quantized. Therefore, it may be desirable to convert from
the original master file rather than from the IMF IAB mezzanine.

[c] .xml (pmstitch) files can include .atmos, .mxf, .rpl, and .wav (ADM BWF) files. Import supported with new compositions and command-line
options.

The Conversion Tool is not intended for use with Dolby Atmos VR masters. The tool does not support VR
metadata.

Related information

Converting the format and other metadata of a master file (conversion window) on page 60
Performing tool operations with an .xml (pmstitch) file on page 90
Performing tool operations with command-line options on page 96

5.3 Sample rate considerations
All Conversion Tools workflows support converting from a source 48 kHz master file format to a target
48 kHz master file format. Additionally, the tool supports converting from a 96 kHz .atmos master file to any
48 kHz master file format except .rpl.

5.4 Considerations when setting the frame rate
The source and target frame rates are important parameters in Dolby Atmos mastering and encoding, and
must be set appropriately. Additionally, supported frame rates are dependent on the master file format.

5.4.1 Source frame rates
When a Dolby Atmos master file is loaded into the Conversion Tool, the tool interprets the frame rate (and
whether it can be edited) based on the source file format, version, and frame rate.

When working on a composition, the frame rate of each master must match. Attempting to import a master
with a different frame rate than the current masters in the MASTER FILES list results in an error message.

Supported Dolby Atmos master file formats
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When importing an .rpl master file, how you set the frame rate is based on the workflow:

• After importing an .rpl into the Conversion window, the source frame rate drop-down menu displays
under the file name. By default, this menu sets the source frame rate. Depending on the frame rate and
length of the master, changing this value may also change these timecode values in the Output section:
target frame rate, and output start, end, and duration.

• When importing an .rpl into the Composition window, you will be prompted to set a frame rate, which
also is used to set the composition frame rate.

Table 10: Source frame rates for Dolby Atmos master file formats

Dolby Atmos master file
format

Versions [a] Frame rate, as specified in
the source file program-
level metadata

Source frame rate [b]

.atmos v0.4 or v0.5 23.976, 24, 25, 29.97, 29.97
drop frame (DF), or 30 fps

As specified

.atmos or .damf v0.3 and earlier Not specified 23.976 fps

.mxf (DCP IAB) v1.0.0.6 24, 25, or 30 fps As specified

.mxf (IMF IAB) All 23.976, 24, 25, or 30 fps As specified

.rpl All Not specified 24, 25, or 30 fps (as set)

.wav (ADM BWF) All 23.976, 24, 25, 29.97, 29.97
DF, or 30 fps

As specified

.xml (pmstitch) All 23.976, 24, 25, 29.97, 29.97
DF, or 30 fps

As specified

[a] The versions column refers to the release number of the specification for the format. To see the version for a home theater master,
open the .atmos or .damf file of the master with a plain text editor, and look at the first line of code.

[b] This is the frame rate interpreted by the tool. It is shown below the file name (in the Conversion window) and in the advanced
metadata section (in the Composition window). While the target frame rate defaults to the source in Conversion mode, it can be
changed.

5.4.2 Target frame rates
The Conversion Tool supports frame rate conversions. The tool allows setting a target frame rate that is
different from the source frame rate. All Dolby Atmos master file formats support editing the target frame
rate.

After importing a master file, the tool sets both the source and target frame rate to the source frame rate.

When the target format does not support the source frame rate,

• When using the tool GUI: The unsupported frame rate is not included in the target Frame rate drop-
down menu (in the Output section).

• When using the command-line application: A message informs you that the target frame rate value is not
supported by the target format.

Table 11: Supported target frame rates

Dolby Atmos master file format Supported target frame rates

.atmos (or .damf) 23.976, 24, 25, 29.97, 29.97 drop frame (DF), or 30 fps

.mxf (IMF IAB) 23.976, 24, 25, or 30 fps

.rpl 24, 25, or 30 fps

.wav (ADM BWF) 23.976, 24, 25, 29.97, 29.97 DF, or 30 fps

Dolby Atmos Conversion Tool overview of workflows and considerations
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5.4.3 Frame rate conversion ratios
When converting to a different frame rate, the Conversion Tool performs a scaling of the playback speed by
a specific ratio. The audio duration and pitch will also change by the same ratio as the different source and
target frame rates.

A faster playback speed results in a shorter duration and a higher pitch. In some cases, if the difference
between the selected input and output frame rates is large, the change in playback speed or pitch may be
greater than desired for the program.

In this table, the ratio of input playback speed (the source frame rate) to output speed (the target frame
rate) is shown for all the possible combinations of frame rates in the drop-down menus. The conversion ratio
is represented in a percentage (for example, converting from 24 fps to 25 fps is -4%).

Note:

The IMF IAB format does not support 29.97 or 29.97 DF as a source or target frame rate.

Note: The .rpl format supports 24, 25, and 30 fps only as a source or target frame rate.

Table 12: Frame rate conversion ratios (playback speed for source and target files)

Source frame
rate (fps)

23.976 fps
target

24 fps target 25 fps target 29.97 fps
target

29.97 DF
target

30 fps target

23.976 0 -0.1% -4.1% 0% 0% -0.1%

24 +0.1% 0 -4% +0.1% +0.1% 0%

25 +4.27% +4.17 0% +4.27% +4.27% +4.17%

29.97 0% -0.1% -4.1% 0% 0% -0.1%

29.97 DF 0% -0.1% -4.1% 0% 0% -0.1%

30 +0.1% 0% -4% +0.1% +0.1% 0%

5.4.4 Frame rate considerations when converting
Before converting, there are specific prerequisites that you should always perform.

• When converting to a Dolby Atmos master, note the selected target frame rate (or include it in the name
of the directory) to ensure that you know what frame rate was applied during the conversion process.

• When converting from an .rpl file, set the source frame rate to the frame rate used during print master
recording (typically 24 fps, but can also be 25 or 30).

5.5 Considerations when setting the FFOA
The FFOA is an important parameter in Dolby Atmos mastering and encoding, and must be set
appropriately.

The FFOA indicates the first frame of video and is generally used for encoding to match the video start for
synchronization. For example, a master file may have been recorded with a starting offset time of 0:59:52:00
(3,592 seconds), and the bitstream encode needs to start later, at 1:00:00:00, to be in sync with the start of
active video. In this case, set the FFOA to 1:00:00:00. The tool automatically interprets it as real time or as
SMPTE NTSC time for pull-down frame rates such as 23.976 or 29.97.

With Dolby Atmos Conversion Tool v2.0, you can choose not to include the FFOA, using either the Dolby
Atmos Conversion Tool GUI or CLI. Additionally, files with FFOA on subframe boundaries are rounded to the
nearest frame on import.

Frame rate conversion ratios
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The FFOA is also used during frame-rate conversion to anchor any time-scale expansion or contraction
required. This means that the first audio samples at the source FFOA time will still be heard at that same
FFOA time after frame-rate (fps) modification. A wrong FFOA can lead to the desired start of program
occurring at the wrong timecode value on the timeline.

You typically set the FFOA in .atmos master file sets created with the Home Theater Renderer software during
master recording. Version 0.4 and 0.5 .atmos files can carry the FFOA, but it is optional. Version 0.3 .atmos files
did not carry the FFOA. You can open the file in the Dolby Atmos Renderer to see the FFOA value (if present).

Note:

The IMF IAB file format does not support FFOA. Instead, all files start at 00:00:00:00.

Note: The DCP.mxf file format has an offset of 00:00:00:00. It does support FFOA.

If the FFOA is not present in a file format that supports FFOA, be sure to check any mastering notes and enter
a value in the Dolby Atmos Conversion Tool accurately before starting conversion to another Dolby Atmos
master file type, or before frame rate (fps) or FFOA conversion operations. If it was included, but is wrong,
you can override the value in the field provided in the tool. As noted, the FFOA can be used in Dolby
bitstream encoders to set the start point of the encode, trimming off the beginning audio samples. If the
master file was created with no leading silent portion, and encoding should start from the very first audio
samples of the master file, the FFOA must correspond to the starting offset time of the source master file.

5.6 Hard disk space requirements
Before using the Conversion Tool, verify hard drive space.

Conversion Tool conversions and operations create masters that can be more than 100 GB in size. For
example, if stitching source content that adds up to approximately 100 GB in size, verify that there is
approximately 150 GB free storage space on the destination drive (the location where the new master will be
created). The operation will fail if there is not enough space to successfully stitch the new content.

5.7 Persistent application data
When you quit the Dolby Atmos Conversion Tool application (or close the Conversion or Composition
window), certain data is retained for the next time you start a new conversion or composition.

To clear persistent data and reset the application to use default data, delete the Conversion Tool preference
files.

Persistent data when working in the conversion window

• Source path for importing a master or .xml (pmstitch) file
• Destination path for the target master

Note: The frame rate is taken from the source master.

Persistent data when working in the composition window

• Source path for importing a master or .xml (pmstitch) file
• Destination path for the target master
• Composition section values:

• Start time
• FFOA (Add FFOA switch setting and timecode value)

• Output section values:

• File format

Dolby Atmos Conversion Tool overview of workflows and considerations
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• Primary language (IMF IAB .MXF master only)

Note: The frame rate is taken from the source master.

5.7.1 Deleting the Conversion Tool application preference files
You can clear persistent data in the Conversion Tool application and reset the tool to use default data, by
deleting the preference files for your operating system.

Procedure

1. On Mac, perform these steps:

a) Open the Finder
b) Choose Go > Go to Folder.
c) Enter the path:

~/Library/Preferences
d) Click Go.
e) Command-click on the two preference files:

com.dolby.AtmosConversionTool.ini

com.dolby.atmoscontroltool.plist
f) Perform one of these steps:

• Right-click on the preference files, and choose Move to Trash.
• Drag the preference files to the trash.

2. On Windows, perform these steps:

a) Navigate to the C:\ProgramData\Dolby\Atmos Conversion Tool\ folder.
b) Delete this file:

AtmosConversionTool.ini

Deleting the Conversion Tool application preference files
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6 

Performing conversions in the conversion
window
In the Conversion window, you can convert the format, frame rate, FFOA, or primary language (IMF
IAB only) of a Dolby Atmos master.

• Creating a new conversion
• Importing a master file for a new conversion
• Converting the format and other metadata of a master file (conversion window)

Performing conversions in the conversion window
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6.1 Creating a new conversion
Before you convert a master file in the Conversion window, you create a new conversion. This opens the
Conversion window, which provides the UI for importing a master, configuring the target master, and then
starting your conversion.

Procedure

1. Launch the Dolby Atmos Conversion Tool.

2. Start a new conversion by performing one of these steps:

• Click New Conversion in the home window.
• Choose File > New Conversion.

Alternatively, you can press Command + N (Mac) or Control + N (Windows).

The Conversion window displays.

What to do next
Import a master file.

Note: You can return to the home window at any time by choosing File > Close. Alternatively, you
can press Command + W (Mac) or Control + W (Windows).

6.2 Importing a master file for a new conversion
After creating a new conversion, you are ready to import a master file.

Prerequisites
Create a new conversion in the Conversion Tool.

About this task

Alternatively, you can create a new composition, and then import and convert a file using the Conversion
Tool composition controls. When performing a new composition, the tool also supports importing an .xml
(pmstitch) file.

Procedure

Add a master to the Conversion window by performing one of these steps:

• Drop a master file into the Conversion window.
• Click in the Conversion window, and then use your browser to locate and choose a master file.

• Choose File > Import Master File.

Alternatively, you can press Command + I (Mac) or Control + I (Windows).

Creating a new conversion
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A loading message and progress bar display in the middle of the window to show the progress of the
import.

What to do next
You are now ready to perform a conversion.

6.3 Converting the format and other metadata of a master file
(conversion window)
In the Conversion window, you can convert the format, frame rate, FFOA, or primary language (IMF IAB only)
of a Dolby Atmos master.

Prerequisites

• Create a new conversion, and then import a master file.

About this task

Perform a new conversion (in the Conversion window):

• When you do not need to change the length of the master, or change the start time
• When you want to preserve source start and end timecodes that are on non–frame boundaries.

Alternatively, you can perform a new composition (in the Composition window, in the timeline).

Before performing a conversion, review these considerations:

• During conversion, the frame rate can also be converted. For example, you can change from the common
cinema rate of 24 fps to a common home theater rate (such as 23.976 or 25 fps).

• When converting to a format that does not support the target frame rate, you will receive an
Unsupported frame rate message that informs you that the frame rate has been changed.

• After importing an .rpl into the Conversion window, the source frame rate drop-down menu displays on
the top-left side of the window. By default, this menu sets the target frame rate. It can also be used to
change the target frame rate value, and to see the output start, end, and duration timecode for different
frame rates.

• When converting to an .mxf (IMF IAB) master file:

• If converting from a file that starts or ends between frames, the Conversion Tool will pad the start or
end to the next frame and warn you. This is because the IMF IAB format requires all IMF IAB files to
start and end on a frame boundary.

• If converting from another format, the frame size is compressed in sections where the audio signal is
silent (-120 dB or below). This may result in significant file size reduction.

• The FFOA is not included.
• You have the option to set the primary language.

• When converting to the .atmos, .mxfs (IMF IAB), or .wav (ADM BWF) file format from an input .atmos (or .damf)
or .rpl file, you can include a .dbmd metadata file with customized Dolby encoding parameters.

Note: An .atmos master file set created with Renderer v3.2 and later includes a .dbmd file. Before
converting, you can manually update (or replace) the .dbmd file. Be sure to use the same file name
so that it remains associated with the top-level .atmos file.

Procedure

1. In the Output section, click the File format drop-down menu, and select the master file format that you
want to convert to.

Performing conversions in the conversion window
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Figure 39: Selecting the target file format

2. (Optional) If you want to apply frame rate conversion, click the Frame rate drop-down menu, and select
a target frame rate.

Figure 40: Selecting the target frame rate

3. (Optional) Set the FFOA by performing one of these steps:

• If you want to not include the FFOA for master formats that support changing the FFOA, disable the
Add FFOA switch.

• If you want to set the FFOA for master formats that support changing the FFOA, enable the Add FFOA
switch, and then set the FFOA.

The FFOA must be the same as or later than the offset in the .atmos or .wav file, and before the last
frame of the file.

Note: Offset is the timecode value of the start of the master.
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The FFOA is the reference point for the start of picture that the audio needs to sync with, and is
typically the starting point when encoding the audio. The FFOA is used as a reference point during
frame-rate conversion, so the audio will start at the same frame before and after conversion.

4. (Optional) If converting to .mxf (IMF IAB), set the primary language by performing one of these steps:

• Click the Primary language drop-down menu, scroll to the desired language, and then click
(highlight) a language.

Figure 41: Selecting the target primary language (IMF IAB only)

• Click in the Primary language field, highlight the existing text (if any), type the first letters of the
desired language, scroll to the language, and then click (highlight) the language:

• Pressing Escape returns the last selected language.
• The field is not character sensitive. You can enter uppercase or lowercase characters to discover a

language.

5. Click the Convert button.

6. Select a file name and destination for the target file, and then click Save to begin the conversion process.

When the target format is .atmos, .wav (ADM BWF), or .mxf (IMF IAB), the output file name for a conversion
uses the source file name by default (Mac only).

The file name for an .rpl master must be dub_out.rpl.

7. When the conversion completes and the File exported successfully message appears, click OK.

This returns you to the Conversion window and the most recent master and conversion settings.

8. (Recommended) Perform a quality control (QC) listening pass on the result.

Use the Dolby Atmos Renderer, or another application that supports playback of a Dolby Atmos master
file.

9. Redo the conversion with new settings, as needed, and then choose File > Close to return to the
Conversion Tool home window.
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7 

Editing, joining, or converting Dolby Atmos
clips in a composition
The Dolby Atmos Conversion Tool lets you create a Dolby Atmos composition, where you can import
one or more masters as individual clips, and then edit clips, join clips, or convert a clip to another
Dolby Atmos master file format.

• Creating a new composition
• Importing master files for a composition
• Removing a master or clip in the composition window
• Viewing master file and clip metadata
• Setting timecode fields
• Inserting silence before or after a clip
• Trimming a clip
• Splitting a clip
• Joining masters
• Converting the format of a master file (composition window)
• Converting a composition
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7.1 Creating a new composition
Before you can work with one or more clips in a composition, you create a new composition. This opens the
Composition window, which provides the UI for importing one or more masters as a clip, and then
performing composition tasks.

Procedure

1. Launch the Dolby Atmos Conversion Tool.

2. Start a new composition by performing one of these steps:

• Click New Composition in the home window.
• Choose File > New Composition.

Alternatively, you can press Command + Shift + N (Mac) or Control + Shift + N (Windows).

The Composition window displays.

What to do next
Import one or more master files.

Note: You can return to the home window at any time by choosing File > Close. Alternatively, you can
press Command + W (Mac) or Control + W (Windows).

7.2 Importing master files for a composition
After creating a new composition, you are ready to import one or more supported master files.

You can import files into the MASTER FILES list first, to later drop them into the Composition window
timeline as a clip. Alternatively, you can import files directly to the timeline. Files imported directly into the
timeline will also be placed in the MASTER FILES list.

A master added to the timeline is considered an editable clip.

7.2.1 Importing a master file to the timeline
After creating a new composition, you can import one or more master files to the timeline. Files imported
directly into the timeline will also be placed in the MASTER FILES list.

Prerequisites
Create a new composition in the Conversion Tool.

About this task
Each master is imported into the timeline as an editable clip, as well as the MASTER FILES list.

Each master for a composition must have the same frame rate.

When importing an .rpl master file, you will be prompted to set a frame rate, which also is used to set the
composition frame rate.

Procedure

1. If the timeline is empty, perform one of these steps:

• Select one or more masters (for example, on a hard drive), and then drag and drop them into the
timeline.
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Figure 42: Example of dropping four files into the timeline

• Click in the empty timeline, browse to the location of your masters (for example, on a hard drive),
select one or more of them, and complete the import.

2. If the timeline already has one or more clips, select one or more master files (for example, on a hard
drive), and drag and drop them to the timeline.

You can drag and drop masters before, after, or in between clips in the timeline.

Results
A loading message and progress bar display in the middle of the window, to show the progress of the import.

What to do next
You are now ready to work with the clips in the timeline.

7.2.2 Importing a master to the master files list
If you want to create a list of masters for editing, joining, or converting at a later time, you can import one or
more masters directly into the MASTER FILES list only. This is also useful for working with like compositions
(such as ones that share one or more masters).

Prerequisites
Create a new composition in the Conversion Tool.

About this task
Each master is imported into the MASTER FILES list.

Procedure

• Reveal the MASTER FILES list, select one or more masters (for example, on a hard drive), and drag and
drop them into the list.

Importing a master to the master files list
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Figure 43: Example of dropping four master files into the master files list

• Choose File > Import Master File, navigate to your masters, select one or more of the masters, and
complete the import.

Alternatively, you can press Command + I (Mac) or Control + I (Windows).

Results
A loading message and progress bar display at the top of the MASTER FILES list to show the progress of the
import.

What to do next
You can add a master from the list to the composition timeline as an editable clip.

7.2.3 Opening an .xml (pmstitch) file
After creating a new composition, you can open an .xml pmstitch file so that it imports the associated stitched
master into the master file list and timeline simultaneously.

Prerequisites

• Create a new composition in the Conversion Tool.
• Verify that each Dolby Atmos master file associated with the .xml (pmstitch) file is at the path specified in

the .xml file.

About this task
When you import an .xml (pmstitch) file, existing masters in the MASTER FILES list and timeline are cleared. If
you have masters in the timeline, you will be prompted with a message that the composition will be
replaced and changes will be lost. Choose OK to import the file, or Cancel to stop the operation.

Procedure

• Choose File > Open .xml (pmstitch), navigate to the file, select it, and complete the import.
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Alternatively, you can press Command + O (Mac) or Control + O (Windows).

Results
A loading message and progress bar display in the middle of the window, to show the progress of the import.

What to do next
You are now ready to work with the clip in the timeline.

7.2.4 Adding a master from the master files list to the timeline
You can add a master from the MASTER FILES list to the timeline as a clip, so that you can work on it. When
there are existing clips in the timeline, you can choose to drop the master before or after any of the clips in
the timeline.

Prerequisites
Create a new composition in the Conversion Tool.

About this task
Each master is added to the timeline as an editable clip.

Each master for a composition must have the same frame rate.

When importing an .rpl master file, you will be prompted to set a frame rate, which also is used to set the
composition frame rate.

Procedure

1. Click (highlight) a master in the MASTER FILES list.

2. If the timeline is empty, perform one of these steps:

• Drag the file from the list, and drop it in the empty timeline.
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Figure 44: Dragging a master from the list

• Choose Timeline > Add Master File To Timeline.

Alternatively, press Command + J (Mac) or Control + J (Windows).

3. If the timeline has one or more clips, perform one of these steps:

• Drag the file from the list, and drop it before or after a clip in the timeline.

Note: When dragging before or after a clip, the silence bar display turns blue to show where
you are dropping the file.

Figure 45: Dropping a file before a clip

Figure 46: Dropping a file after a clip

• Choose Timeline > Add Master File To Timeline.

This places the master after the last master in the timeline.

Alternatively, press Command + J (Mac) or Control + J (Windows).

4. (Optional) Add more masters to the timeline.

What to do next
You are now ready to work with the clips in the timeline.
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7.3 Removing a master or clip in the composition window
When working on a composition, you can remove a master from the master file list, or a clip from the
timeline. You can also clear all clips from the timeline.

7.3.1 Removing a file from the master files list
When working on a composition, you can remove a master from the MASTER FILES list.

Prerequisites
There are one or more masters in the MASTER FILES list.

About this task
Removing a file from the list also removes any instance of the file (as a clip) from the timeline. You will be
prompted with a warning if the master exists as a clip on the timeline.

Procedure

1. In the MASTER FILES list, click (highlight) the master that you want to remove.

2. Perform one of these steps:

• Click Delete (Mac US QWERTY) or Backspace (Mac International QWERTY, or Windows).
• Right-click on the master, and select Remove master file.

• Choose Edit > Remove Master File.

3. If the master exists as a clip on the timeline, click Remove master when prompted.

7.3.2 Removing a clip from the composition timeline
When working on a composition, you can remove a clip from the timeline.

Prerequisites
There are one or more clips in the composition timeline.

About this task
Removing a clip from the timeline keeps the associated master in the MASTER FILES list.

Procedure

1. In the composition timeline, click (highlight) the clip that you want to remove.

2. Perform one of these steps:

• Click Delete (Mac US QWERTY) or Backspace (Mac International QWERTY, or Windows).
• Right-click on the clip, and select Remove from timeline.
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• Choose Edit > Remove From Timeline.

7.3.3 Clearing clips in the timeline
When working on a composition that has one or more clips in the timeline, you can clear all of the clips in
the timeline.

Prerequisites
There are one or more clips in the composition timeline.

Procedure

1. Choose Timeline > Clear Timeline.

2. In the Clear timeline dialog, click Clear timeline.

7.4 Viewing master file and clip metadata
When working on a composition, you change how clips and clip metadata display in the composition
timeline and Composition section. Additionally, you can display detailed (advanced) metadata for clips or
masters, or the length of a silence clip.

Procedure

• To view the start, end, and duration of a clip, relative to the start of the master file associated with the
clip, perform one of these tasks:

• Hover over the clip in the timeline.

• Select the clip in the timeline.
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• Click on the composition bar for the clip in the Composition section.

• To view the start, end, and duration of a clip, relative to the composition start time, perform one of the
tasks:

• Hover over the composition bar for the clip in the Composition section.

• Click on the composition bar for the clip in the Composition section.

Viewing master file and clip metadata
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• To display advanced metadata of a master or clip, or the length of a silence clip, perform these steps:

a) Choose View > Show Advanced Metadata, or click the advance metadata icon  at the top-right

corner of the Composition window.

Alternatively, you can press Command + Shift + P (Mac) or Control + Shift + P (Windows).
b) Perform the task for the desired advanced metadata:

• To display the advanced metadata of a master, click the master in the MASTER FILES list.

• To display advanced metadata of a clip, click the clip in the timeline, or click on the bar for the clip
in the Composition section.

• To display the length of a silence clip, click the silence clip in the timeline.
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• To hide advanced metadata, perform one of these steps:

• Click the blue advanced metadata icon in the Composition window.
• Click the X at the top-right corner of the Composition window.
• Press Command + Shift + P (Mac) or Control + Shift + P (Windows)

• To display the timecode location relative to the clip (in the timeline) and relative to the composition (in
the Composition section, hover over the timeline so that the cursor appears. Move the mouse to the left
or right to display other timecode locations.

• To scroll through the clips in the timeline, click on the scroll bar (located at the bottom of the timeline),
or anywhere in the timeline above or below the clips, and scroll to the left or right.

• To zoom in, zoom out, or zoom to fit, perform the respective steps using the menu zoom slidebar, menu
command, or keyboard shortcut:

Figure 47: Zoom slide bar

Note: On Mac, you can also use standard macOS trackpad and mouse shortcuts for zooming.
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• To zoom in on the clips in the timeline, click on the zoom slide bar and drag it to the right (toward the
plus symbol), or choose View > Zoom In.

Alternatively, you can press Command + the plus symbol (Mac) or Control + the plus symbol
(Windows).

• To zoom out on the clips in the timeline, click on the zoom slide bar and drag it to left (toward the
minus symbol), or choose View > Zoom Out.

Alternatively, you can press Command + the minus symbol (Mac) or Control + the minus symbol
(Windows).

• To zoom so that all the clips display in the visible timeline, click on the zoom slide bar and drag it all
the way to the left, or choose View > Zoom to Fit.

Alternatively, you can press Command + 0 (Mac) or Control + 0 (Windows).

7.5 Setting timecode fields
When working on a composition, you can set timecode values for various tasks.

About this task
Depending on the source and target format, these tasks can include timecode values that can be set before
a conversion:

• Setting the start time of a composition (the start of the target master)
• Setting the FFOA
• Inserting silence before or after a master
• Trimming a master
• Splitting a master

Procedure

• Use the up and down arrow keys to change a value, or type in a valid value.
• Use the left and right arrow keys to toggle through the timecode unit (such as hours, seconds, minutes,

samples), or click on a different time.
• Copy and paste timecode values.

7.6 Inserting silence before or after a clip
In the composition timeline, you can insert silence (add padding) before or after a clip. You can also add
silence before or after an existing silence clip, or edit the length of existing silence clip.

Prerequisites
Ensure that one or most masters have been added as clips to the timeline.

About this task

Alternatively, you can use the Conversion Tool command-line application to implement the operation.

Procedure

1. If desired, insert silence before (or after) a clip:

a) In the timeline, perform one of these steps.

• Hover over the empty silence bar located to the left (or right) of the clip, so that it changes to
green with a + sign in the middle of it, and then click on it.
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• Click (highlight) the clip, and then choose Timeline > Add Silence > Before Selected Clip (or After
Selected Clip).

b) In the Insert silence window, in the Length field, add the amount of desired silence.
c) Click the Insert button.

2. If changing the length of a silence clip, perform these steps:

a) Right-click on the silence clip, which is represented by a green moiré pattern, and then choose Edit
length.

b) In the Change length window, in the Length field, add the amount of desired silence.

c) Click the Change button.

Results
The silence is inserted.

What to do next
Perform other composition edits, as needed, until you are ready to convert the composition.
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7.7 Trimming a clip
In the composition timeline, you can trim a clip at both ends, or at the start or end.

Prerequisites
In a composition, ensure that the clip is in the timeline.

About this task

Alternatively, you can use the Conversion Tool command-line application to implement the operation.

To undo your edits prior to starting the conversion, right-click on the clip and select Reset to original.

Procedure

1. If you want to trim the start and end of the clip, perform these steps:

a) Click (highlight) the clip in the timeline to select it.
b) Perform one of these steps:

• Right-click on the clip, and choose Trim.
• Choose Timeline > Trim.

c) In the Trim window, set the From and To values to the new start and end times, respectively.

d) Click the Trim button.

2. If you want to trim the start of the clip only, perform these steps:

a) Click (highlight) the clip in the timeline to select it.

b) Hover over the left edge of the clip so that the  cursor displays, and then click and drag the

cursor to the right, or click on it.
c) In the Trim window, set the Start of the clip.

d) Click the Trim button.

3. If you want to trim the end of the clip only, perform these steps:

a) Click (highlight) the clip in the timeline to select it.
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b) Hover over the left edge of the clip so that the  cursor displays, and then click and drag the

cursor to the left, or click on it.
c) In the Trim window, set the End of the clip.

d) Click the Trim button.

Results
The clip is trimmed.

What to do next
Perform other composition edits, as needed, until you are ready to convert the composition.

7.8 Splitting a clip
In the composition timeline, you can split a clip into two clips, and then edit the two clips as desired.

Prerequisites
In a composition, ensure that the clip is in the timeline.

About this task

To undo your edits prior to starting the conversion, right-click on the clip and select Reset to original.

Procedure

1. If using the cursor (to split at a specific location), perform these steps:

a) In the timeline, move the cursor over the clip until you see the time where you want to perform the
split.

This is the location relative to the start of the clip. Alternatively, you can view the cursor in the
Composition (in source fps) section relative to the start time, and then move the mouse vertically
upward until the cursor is in the clip.

b) Right-click at the location, and choose Split.
c) In the Split window, verify the Location, and then click Split.
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2. If using the Timeline > Split command, perform these steps:

a) Click (highlight) the clip in the timeline.
b) Choose Timeline > Split.

Alternatively, press Command + E (Mac) or Control + E (Windows).
c) In the Split window, in the Location field, set the split location.
d) Click the Split button.

Results
The clip is split.

What to do next
Perform other composition edits, as needed, until you are ready to convert the composition.

7.9 Joining masters
In the Composition window, you can sequentially order multiple clips, and then join them together.

About this task

• Alternatively, you can use the Conversion Tool command-line application to implement the operation.
• All masters in the composition must have the same sample rate.
• During a join operation, you can do other tool operations. For example, you can convert the frame rate.
• When joining together masters that have different bed widths or a different number of beds or objects,

the beds are flattened into a single 9.1 bed. For example, this occurs when joining a master that contains
a single 9.1 bed with a master that contains three 5.1 beds. If you wish to preserve access to the
individual beds (when importing the master into a digital audio workstation (DAW)), we recommend that
you archive the original source masters in addition to the new joined master. When joining together
masters that have the same bed widths, the bed layout is preserved.

When beds are flattened, the objects are organized sequentially after the 9.1 bed. If the number of
objects is different between masters, the output master will have the largest number of objects in any
one master.

• You cannot join 96 kHz master format files. You must first convert the files to 48 kHz.
• To join an .xml (pmstitch) file to other master files, you must import the .xml (pmstitch) first into a new

composition.

Procedure

1. Start a new composition.

2. In the Composition window, import masters to the composition timeline as clips, or add masters from
the MASTER FILES list to the timeline as clips.

3. Order the clips as desired.

Editing, joining, or converting Dolby Atmos clips in a composition

Dolby Atmos Conversion Tool v2.0 Software Guide 78

30 April 2020



You can click on a master in the MASTER FILES list and drag and drop it into the timeline as a clip, before
or after other clips.

You can click on a clip in the timeline and drag it to a new location (for example, before or after other
clips).

4. Choose which master associated with a clip should be considered the primary master for the converted
master.

The primary master defines the metadata values to be used.

Figure 48: Selecting the primary master

5. (Optional) Insert silence before or after any clips.

6. Set the composition start time.

In the Composition section, click in the Start field, and then set a valid composition start time.

The start value must not result in the composition duration crossing the midnight (24 hour) boundary.
Adjust the start time (or shorten the duration of the timeline), as needed.

7. (Optional) Set the FFOA in the Composition section by performing one of these steps:

• If you want to not include the FFOA for master formats that support changing the FFOA, disable the
Add FFOA switch.

• If you want to set the FFOA for master formats that support changing the FFOA, enable the Add FFOA
switch, and then set the FFOA.

The FFOA must be the same as or later than the offset in the .atmos or .wav file, and before the last
frame of the file.

Joining masters

Dolby Atmos Conversion Tool v2.0 Software Guide 79

30 April 2020



Note: Offset is the timecode value of the start of the master.

The FFOA is the reference point for the start of picture that the audio needs to sync with, and is
typically the starting point when encoding the audio. The FFOA is used as a reference point during
frame-rate conversion, so the audio will start at the same frame before and after conversion.

What to do next
Perform other composition edits, as needed, until you are ready to convert the composition into a single
master.

7.10 Converting the format of a master file (composition window)
Use the Conversion Tool application to convert one Dolby Atmos master file format to another.

Prerequisites

• Create a new conversion or new composition, and import a master file.
• If converting with a composition, make sure that the master has been imported to the timeline (as a clip)

in the Composition window.

About this task

Perform a new conversion (in the Conversion window):

• When you do not need to change the length of the master, or change the start time
• When you want to preserve source start and end timecodes that are on non–frame boundaries.

Perform a new composition (in the Composition window, in the timeline):

• When you want to change the length of the master (for example, by trimming or inserting silence at the
start of the master)

• When you want to change the start time of the master
• When it is acceptable for the source start and end times to extend to the nearest frame boundary, if on a

subframe

Before performing a conversion, review these considerations:

• During conversion, the frame rate can also be converted. For example, you can change from the common
cinema rate of 24 fps to a common home theater rate (such as 23.976 or 25 fps).

• When converting to a format that does not support the target frame rate, you will receive an
Unsupported frame rate message that informs you that the frame rate has been changed.

• After importing an .rpl file into the Conversion window, the source frame rate field displays on the top-
left side of the window. You can use this menu to change the target frame rate value, and see output
start, end, and duration timecode using the frame rate.

• When converting to an .mxf (IMF IAB) master file:

• If converting from a file that starts or ends between frames, the Conversion Tool will pad the start or
end to the next frame and warn you. This is because the IMF IAB format requires all IMF IAB files to
start and end on a frame boundary.

• If converting from another format, the frame size is compressed in sections where the audio signal is
silent (-120 dB or below). This may result in significant file size reduction.

• The FFOA is not included.
• You have the option to set the primary language.

• When converting to the .atmos, .mxf (IMF IAB), or .wav (ADM BWF) file format from an input .atmos (or .damf)
or .rpl file, you can include a .dbmd metadata file with customized Dolby encoding parameters.
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Note: An .atmos master file set created with Renderer v3.2 and later includes a .dbmd file. Before
converting, you can manually update (or replace) the .dbmd file. Be sure to use the same file name
so that it remains associated with the top-level .atmos file.

• If an invalid .xml (pmstitch) or other Dolby Atmos master file is imported, an error message is displayed.
The error message indicates if the issue is with the .xml syntax or file path.

• The error message will indicate if the issue is with the .xml syntax or file path(s).

Procedure

1. In the Output section, click the File format drop-down menu, and select the master file format that you
want to convert to.

Figure 49: Selecting the target file format

2. (Optional) If you want to apply frame rate conversion, click the Frame rate drop-down menu, and select
a target frame rate.

Figure 50: Selecting the target frame rate

3. (Optional) Set the FFOA by performing one of these steps:

• If you want to not include the FFOA for master formats that support changing the FFOA, disable the
Add FFOA switch.
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Figure 51: Disabling the Add FFOA switch

• If you want to set the FFOA for master formats that support changing the FFOA, enable the Add FFOA
switch, and then set the FFOA.

Figure 52: Enabling the Add FFOA switch

The FFOA must be the same as or later than the offset in the .atmos or .wav file, and before the last
frame of the file.

Note: Offset is the timecode value of the start of the master.

The FFOA is the reference point for the start of picture that the audio needs to sync with, and is
typically the starting point when encoding the audio. The FFOA is used as a reference point during
frame-rate conversion, so the audio will start at the same frame before and after conversion.

4. (Optional) If converting to .mxf (IMF IAB), set the primary language by performing one of these steps.

Figure 53: Selecting the target primary language (IMF IAB only)

• Click the Primary language drop-down menu, scroll to the desired language, and then click
(highlight) a language.

• Click in the Primary language field, highlight the existing text (if any), type the first letters of the
desired language, scroll to the language, and then click (highlight) the language:

• Pressing Escape returns the last selected language.
• The field is not character sensitive. You can enter uppercase or lowercase characters to discover a

language.

5. (Optional) If you want to set a new start time, change the value in the Start field.
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The start value must not result in the composition duration crossing the midnight (24 hour) boundary.
Adjust the start time (or shorten the duration of the timeline), as needed.

What to do next
Perform other composition edits, as needed, until you are ready to convert the composition into a single
master.

7.11 Converting a composition
After editing a composition, you can convert the composition to create a new Dolby Atmos master.

Prerequisites
You have created a new composition, imported one or more masters into the timeline, and have performed
composition edits.

Procedure

1. Click the Convert button.

2. Select a file name and destination for the target file, and then click Save to begin the conversion process.

3. After the conversion completes and the File exported successfully message appears, click Return to
timeline.
This returns you to the Composition window, and the most recent clip and composition settings (as well
as the most recent MASTER FILES list).

What to do next
You can continue to work in the Composition window, close the window, and create a new composition or
conversion, or quit the tool.
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8 

Dolby Atmos master file formats
Dolby Atmos master file formats (or media files) include master files or file sets created in a home
theater workflow, cinema print masters, and other related Dolby Atmos files.

The Dolby Atmos Conversion Tool supports the files noted in this documentation.

Dolby Atmos master file formats include:

• .atmos: Home theater master file set.
• .damf: Older (original) home theater master file set.
• .mxf (DCP IAB): Encoded .mxf created with the Dolby Renderer for Cinema. This file format is

considered a mezzanine file format due to metadata quantization.
• .mxf (IMF IAB): Dolby Atmos IAB track file for IMF in a MXF container. This file format is considered a

mezzanine file format due to metadata quantization.
• .rpl: Cinema print master and supporting files.
• .wav (ADM BWF): BWF file containing ADM metadata.

Special files used with Dolby Atmos master files

• .dbmd: Dolby Audio Metadata file that can contain customized Dolby encoding parameters
supported when converting to the .atmos, .mxf (IMF IAB), or .wav (ADM BWF) file format from an
input .atmos (or .damf), or .rpl file.

• .xml (pmstitch): .xml configuration file that was required for editing a master prior to Conversion
Tool v2.x and the introduction of the composition feature. With v2.0, the file can be imported when
doing a new composition, and can be converted to the .atmos, .mxf (IMF IAB), .rpl, or .wav (ADM BWF)
file format.

Dolby Atmos master file formats
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Primary languages supported by the Dolby
Atmos Conversion Tool (IMF IAB only)
When converting to .mxf (IMF IAB) with the Dolby Atmos Conversion Tool application or command-line
options, you can set the primary language.

This tables lists the languages provided with the UI Choose primary language drop-down menu and
the respective codes for setting the primary language with command-line options. The default primary
language is English.

Table 13: Languages and command-line codes for the primary language option

Language Command-line code

Acoli ach

Afrikaans af

Albanian sq

Arabic ar

Arabic (Egypt) ar-EG

Arabic (Lebanon) ar-LB

Arabic (UAE) ar-AE

Aramaic arc

Armenian hy

Azerbaijani az

Bambara bm

Bashkir ba

Belarusian be

Bengali bn

Bosnian bs

Bulgarian bg

Burmese my

Catalan ca

Chechen ce

Cheyenne chy

Chinese (Cantonese) yue

Chinese (Mandarin) cmn

Chinese (Taiwanese Mandarin) cmn-TW
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Table 13: Languages and command-line codes for the primary language option (continued)

Language Command-line code

Croatian hr

Czech cs

Danish da

Dinka din

Dutch nl

Dzongkha dz

Efik efi

Elamite elx

English [a] en

English (Australian) en-AU

English (UK) en-GB

English (US) en-US

Esperanto eo

Estonian et

Faroese fo

Farsi (Afghan, Dari) fa-AF

Farsi (Persian) fa

Filipino fil

Finnish fi

Flemish vls

French fr

French-Canadian fr-CA

Gaelic ga

Georgian ka

German de

German (Austrian) de-AT

Greek el

Gujarati gu

Hawaiian haw

Hebrew he

Hindi hi

Hungarian hu

Icelandic is

Indonesian id

Inuktitut iu

Italian it
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Table 13: Languages and command-line codes for the primary language option (continued)

Language Command-line code

Jamaican Patois jam

Japanese ja

Javanese jv

Kannada kn

Kazakh kk

Khmer (Cambodian) km

Kikuyu ki

Kinyarwanda rw

Kirghiz ky

Korean ko

Kurdish ku

Lango (Uganda) laj

Latin la

Latvian lv

Lingala ln

Lithuanian lt

Luxembourgish lb

Maasai (Masai) mas

Macedonian mk

Malagasy mg

Malay ms

Malayalam ml

Maltese mt

Marathi mr

Maya myn

Mende men

Mongolian mn

Nepali ne

Newari new

Norwegian no

Norwegian (Bokm├Ñl) nb

Norwegian (Nynorsk) nn

Pashtu (Pashto, Pushto) ps

Polish pl

Portuguese pt

Portuguese (Brazilian) pt-BR
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Table 13: Languages and command-line codes for the primary language option (continued)

Language Command-line code

Punjabi pa

Romanian ro

Romansh rm

Romany rom

Russian ru

Sami smi

Scottish Gaelic gd

Sanskrit sa

Serbian sr

Sinhala si

Slovak sk

Slovenian sl

Somali so

Songhai son

Spanish es

Spanish (Argentinian) es-AR

Spanish (Castilian) es-ES

Spanish (Chilean) es-CL

Spanish (Latin American) es-419

Spanish (Mexican) es-MX

Swahili sw

Swedish sv

Swiss-German gsw

Tagalog tl

Taiwanese (Hokkien, Min Nan) nan

Tamashek tmh

Tamil ta

Telugu te

Thai th

Tibetan bo

Tonga to

Turkish tr

Tuvan tyv

Ugaritic uga

Ukranian uk

Urdu ur
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Table 13: Languages and command-line codes for the primary language option (continued)

Language Command-line code

Vietnamese vi

Welsh cy

Wolof wo

Xhosa xh

Yiddish yi

Zapotec zap

Zulu zu

[a] Default
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Performing tool operations with an .xml
(pmstitch) file
On Mac and Windows systems, you can perform Dolby Atmos Conversion Tool operations (including
trimming a master, inserting silence, and joining masters) by using an .xml (pmstitch) file that you import
into a composition.

• .xml (pmstitch) file considerations
• .xml (pmstitch) elements and attributes
• .xml (pmstitch) file examples for Dolby Atmos Conversion Tool operations
• Preparing an .xml (pmstitch) file for a supported Dolby Atmos Conversion Tool operation
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10.1 .xml (pmstitch) file considerations
The .xml (pmstitch) interface was originally designed to join (or stitch) multiple reels of a soundtrack for
cinema release into a full-length print master. The same format is used in the Conversion Tool with
additional capabilities as described in this documentation.

You can load an .xml (pmstitch) file directly into the Conversion Tool UI Composition window (Mac and
Windows), or load the file into the Conversion Tool command-line application (Linux, Mac, and Windows).

Note: An .xml (pmstitch) file can include 48 kHz source masters only.

When joining masters that have different encoding metadata (either within a .dbmd metadata file or the
master), you can specify which source master defines the metadata values to be used for the resulting
master by setting the master as the primary master.

In the application, click on the Primary drop-down menu and select which master is the primary one. When
using the command-line option, add primary="true" to the <source> element. For example:

<source primary="true">

10.2 .xml (pmstitch) elements and attributes
An .xml (pmstitch) file loaded into the Conversion Tool UI window (Mac and Windows), or passed into the
Conversion Tool command-line application (Linux, Mac, and Windows), uses XML elements and attributes to
define padding, joining, trimming, and other operations.

In an .xml (pmstitch) file, an element is a container that can hold text, elements, and attributes. Each element
has a start and end entry (such as <config> and </config>). An attribute is a part of an element that
defines properties of the element. An .xml attribute is always presented as a name=value pair (such as
primary="true”).

<stitch>
Root element of the .xml (pmstitch) file. All .xml (pmstitch) files must start with <stitch> and end with </
stitch>.

<config>
Contains the frame-rate element.

<framerate>
Defines the frame rate of the source included in the operation. Valid values are all frame rates supported
by the source master.

<sources>
Contains the elements and attributes for a list of source masters, including source and output settings.

<source>
Contains the elements and attributes for a source master, including source and output settings. When
joining masters, the primary <source> element contains the primary="true” attribute.

<sources primary="true”>
Specifies which source master defines the metadata values to be used for the resulting master when
joining masters that have different program-level metadata (such as .dbmd parameters).

<path>
Defines the absolute or relative path to the master file. The absolute path is the full location of the file
starting with /volumes (Mac) or with the drive letter:\\ (Windows). If no full path is given, the Conversion Tool
will interpret the path relative to the location of the .xml file and use the location of the .xml (pmstitch) file
as a starting point.
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<sourceStart>
Defines the start time of the source master in relation to the value of the start offset of the source
master. For example, if the source master starts at 1:00:00:00, this value can be set to 1:00:08:00 to skip
the first eight seconds of the content or 59:59:58:00 to add two seconds of silence to the start.

This element is required, unless joining two adjacent masters with no trimming and no gap, in which
case the <sourceStart>, <outputStart>, and <outputEnd> should not be included for all masters.

Note: The timecode is interpreted in the context of the <framerate> value.

<outputStart> (or <start>)
Defines the timecode value of the start offset of the target master.

This element is required, unless joining two adjacent masters with no trimming and no gap, in which
case the <sourceStart>, <outputStart>, and <outputEnd> should not be included for all masters.

• If <outputEnd> is specified to be after the <outputStart> of the next source, it will be disregarded
and the next source <outputStart> field will be used instead.

• If the <count> number of repetitions extends beyond the start of the next source, the repetitions
will be truncated by the next source <outputStart> value.

Note: The timecode is interpreted in the context of the specified frame rate.

Note: With Dolby Atmos Conversion Tool v1.8, <start> and </start> were renamed to
<outputStart> and </outputStart>, respectively, to better describe their function.

<outputEnd> (or <end>)
Defines the timecode value of the last frame of this section of the target master, exclusively. For
example, if the start timecode is set to 1:00:00:00 and end timecode is set to 1:00:08:01, the target
master will be 00:00:08:01 at 24 fps.

This element is required, unless joining two adjacent masters with no trimming and no gap, in which
case the <sourceStart>, <outputStart>, and <outputEnd> should not be included for all masters.

When joining adjacent masters with no trimming and no gap, the absence of an <outputEnd> value
means that the start of the second master determines the length of the previous master. If this is the last
master being joined, then the file will go until the end of its duration.

Note: The timecode is interpreted in the context of the specified frame rate.

Note: With Dolby Atmos Conversion Tool v1.8, <end> and </end> were renamed to <outputEnd>
and</outputEnd>, respectively, to better describe their function.

<count>
Defines the number of times the current print master is repeated in the target master. For example, if
the source master is one second of silence, to get five seconds of silence in the target master, the source
print master may be repeated five times by specifying a count of five.

10.3 .xml (pmstitch) file examples for Dolby Atmos Conversion Tool
operations
Dolby provides .xml (pmstitch) file examples for use when creating a new .xml configuration file for padding a
master, joining together masters, or trimming a master. The examples can also be used to create .xml files for
other tool operations (such as converting the master file format).

You can find examples and supporting media files online, at https://developerkb.dolby.com/support/
solutions/articles/16000103176-where-can-i-find-more-examples-of-pmstitch-xml-files-.
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An .xml (pmstitch) file configured for a tool operation can be imported into the Dolby Atmos Conversion Tool
user interface composition (Mac and Windows), or can be used with the Conversion Tool command-line
application (Linux, Mac, and Windows).

10.4 Preparing an .xml (pmstitch) file for a supported Dolby Atmos
Conversion Tool operation
Prior to using an .xml (pmstitch) file to perform a tool operation, you need to create and edit the file.

Prerequisites

XML or plain text editor such as TextEdit (on Mac) or Microsoft Notepad (on Windows). If creating the file for
use in Linux (with the Dolby Atmos Conversion Tool command-line option), use a Linux text editor (such as
gedit).

About this task

This task creates an .xml (pmstitch) file for use when performing a tool operation with either the Dolby Atmos
Conversion Tool GUI application (on Mac or Windows), or with the Dolby Atmos Conversion Tool command-
line application (Linux, Mac, or Windows).

Procedure

1. Create an .xml (pmstitch) file, or open one of the .xml (pmstitch) example files supplied by Dolby.

2. Include the lines shown in the example file, as needed.

Figure 54: Example: Trimming a master file

<stitch>
    <config>
        <framerate>24</framerate>
    </config>
    <sources>
        <source>
        <!--original start 00:59:58:00
            original end 01:20:00:00
            original duration 00:20:02:00
            operation:
                trims 2 seconds from head (removes 2pop)-->
            <path>/Volumes/Media/DACT_Sample_Media/Reel1_w2pop/Reel1_w2pop.atmos</
path>
            <sourceStart>01:00:00:00</sourceStart>
            <outputStart>01:00:00:00</outputStart>
            <outputEnd>01:00:20:00</outputEnd>
        </source>
    </sources>
    <!--Finished file duration is 00:20:00:00-->
</stitch>

Note: If joining masters, repeat the layout text between the <source> and </source> lines for
each additional source master (clip). Additionally, make sure that all clips to be joined were
created using the same frame rate to ensure proper audio/video (A/V) sync in the output master.
If the frame rates do not match, the conversion will result in an error message.
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Figure 55: Example: Joining multiple masters

<stitch
    <config>
        <framerate>24</framerate>
    </config>
    <sources>
        <!--This example illustrates joining together film reels-->
              <source primary="true">
            <path>/Volumes/Media/DACT_Sample_Media/Reel1/Reel1.atmos</path>
            <sourceStart>01:00:00:00</sourceStart>
            <outputStart>01:00:00:00</outputStart>
            <outputEnd>01:20:00:00</outputEnd>
        </source>
        <source>
            <path>/Volumes/Media/DACT_Sample_Media/Reel2/Reel2.atmos</path>
            <sourceStart>02:00:00:00</sourceStart>
            <outputStart>01:20:00:00</outputStart>
            <outputEnd>01:40:00:00</outputEnd>
        </source>
        <source>
            <path>/Volumes/Media/DACT_Sample_Media/Reel3/Reel3.atmos</path>
            <sourceStart>03:00:00:00</sourceStart>
            <outputStart>01:40:00:00</outputStart>
            <outputEnd>02:00:00:00</outputEnd>
        </source>
        <source>
            <path>/Volumes/Media/DACT_Sample_Media/Reel4/Reel4.atmos</path>
            <sourceStart>04:00:00:00</sourceStart>
            <outputStart>02:00:00:00</outputStart>
            <outputEnd>02:20:00:00</outputEnd>
        </source>
    </sources>
</stitch>

3. In the <config> section, verify the frame rate matches the frame rate of the master (if available), or
change it if desired.

If working with a home theater .atmos master, and you do not know the frame rate of the master, open
the .atmos file with a text editor, and look at the fps value.

4. In the <sources> section, update the <path> for the master folder and file, and then the
<sourceStart>, <outputStart>, and <outputEnd> parameters, based on whether you are trimming
or padding the master, joining masters, or doing another operation.

Note: If joining masters, edit the <sources> section parameters for each source master.

• <path>: Enter the location of the master folder and file (.atmos, .rpl, or .wav). Use the absolute path to
the file.

If you do not use the absolute path, ensure that the .xml (pmstitch) file is in the source directory of the
master that will be converted.

• <sourceStart>: This timecode represents the offset value into the source content. Use this
timecode to set the amount of trim or padding at the front of a single master, or any master when
joining multiple masters.

Source master offset is the value of the offset field in .atmos files, offset field in .rpl files, and
audioProgramme start value for .wav (ADM BWF) files.

• To trim the front of a master, set the <sourceStart> to a value larger than the source master
offset (but less than 24 hours, such as 23:59:59:23 for 24 fps and 23:59:59:29 for 30 fps).

• To add padding (silence) to the front of a master, set the <sourceStart> to a value less than the
source master offset (but not less than 0).

• To add no trimming or padding, set the <sourceStart> to the same value as the source master
offset.
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Note: When joining masters, the <sourceStart> for each master should correspond to the
first videoFrame. The master will be trimmed by the difference between the source offset and
the FFOA.

• <outputStart> and <outputEnd>: These timecode values define the range of the output file. Use
this range to set the amount of trim or padding at the end of a master, or to define the start and end
of each master to be joined.

When joining adjacent masters, if the end of the first clip comes after the start of the next clip, the
start of the second clip is used to determine the length of the first clip.

• To trim the end of a single master, set the <outputStart> and <outputEnd> to define a range
that is less than the length of the file, based on the <sourceStart> timecode.

• To add padding to the end of a single master, set the <outputStart> and <outputEnd> to
define a range that is greater than the length of the file, based on the <sourceStart> timecode.

• To join two adjacent masters with a gap of silence, set the <outputEnd> of the first master to a
value less than the start of the next master by a value greater than one frame.

• To join two adjacent masters with a data overlap, set the <outputStart> of the second master
to a value less than the end of the first master. This trims the length of the first master by the
amount of the overlap.

• To join two adjacent masters with no trimming and no gap, do not include the <sourceStart>,
<outputStart>, and <outputEnd> for all masters.

5. (Optional) Add <count>.

The <count> field sets the number of times the source will be added to the target master (output file)
back-to-back. If you include this field, always set it to a value greater than 1. Setting the field to 1 has no
effect. When <count> is not included in the file, the parameter defaults to 1.

6. Save the file as an .xml (pmstitch) file.
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11 

Performing tool operations with command-
line options
The Dolby Atmos Conversion Tool command-line application and options let you perform tool
operations from a dedicated command-line program on Linux, Mac, and Windows operating systems.

• Command-line application capabilities
• Command-line options
• General steps for command-line tasks
• Using an .xml pmstitch file with command-line options
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11.1 Command-line application capabilities
The Dolby Atmos Conversion Tool command-line application supports using a command-line program to
perform conversion tool operations, including stitching together Dolby Atmos master files.

Note: Command-line operations supersede any similar arguments made with an .xml (pmstitch) file. If
the required information for a parameter (such as input, output, format, or frame rate) is in the .xml
(pmstitch) file, it is not needed in the command-line.

The Dolby Atmos Conversion Tool command-line application supports these tool operations:

• Converting from one Dolby Atmos master file format to another

Note: The command-line application supports converting to or from a 48 kHz master file format.
Additionally, the tool supports converting from a 96 kHz .atmos master file to a 48 kHz file.

• Changing the frame rate of a Dolby Atmos master file
• Changing the FFOA of a Dolby Atmos master file
• Changing the primary language of a Dolby Atmos IMF IAB master
• Converting to .atmos, .mxf (IMF IAB), or .wav (ADM BWF) with a modified .dbmd metadata file, from an .atmos

(or .damf) or .rpl file.
• Trimming or padding a single master (without adding any other segments)
• Stitching multiple masters together

When stitching, you can mix together these Dolby Atmos master formats:

• .atmos files
• DCP .mxf files
• .mxf (IMF IAB) files
• .rpl files
• .wav files

11.2 Command-line options
You can modify operations with command-line options. An additional option displays help.

Table 14: Dolby Atmos Conversion Tool command-line options

Options Shortcut Description

--help -h Displays help (full list of Dolby Atmos Conversion Tool command-line
options).

--version -v Displays the application version, and exits the application.

--verbose -V Enables verbose information for debugging.

--pm_in arg -i Specifies the path to the input Dolby Atmos master file.

--output_path arg
(=.)

-o Specifies the output path for the audio and metadata files. The
default is the current working directory.

--output_format
arg (=atmos)

-f Specifies the output file format: .atmos, .mxf, .rpl, or .wav.

--source_fps arg Specifies the frame rate of the source master file, in frames per
second (fps). This option will set the frame rate of the source master
file that does not specify one. Valid values are dependent on the
frame rate supported by the source master. They can include 23.976,
24, 25, 29.97, 29.97df, and 30 fps.
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Table 14: Dolby Atmos Conversion Tool command-line options (continued)

Options Shortcut Description

--target_fps arg Specifies the frame rate of the target master file. Valid values are
dependent on the frame rate supported by the target master. They
can include 23.976, 24, 25, 29.97, 29.97df, and 30 fps. Numbers near
23.976 and 29.97 will be rounded to (24 × 1,000) ÷ 1001 and (30 ×
1000) ÷ 1001. If this value is equal to the frame rate in the source file,
frame rate conversion is bypassed and the tool does a format
conversion only.

--ffoa arg (=-1) Specifies FFOA. If none is specified, the source master FFOA will be
used.

--no_ffoa arg Specifies to not include FFOA when creating the new master.

-l [ --primary_
lang ] arg

Specifies IMF IAB sound field primary spoken language as RFC 5646
code value. Applicable only for MXF output format. If none is
specified for an input MXF master, its primary language is passed
through to the output. If none is specified for all other master types,
"en" will be used. See Primary languages supported by the Dolby
Atmos Conversion Tool (IMF IAB only).

--list_languages Displays full list of supported RFC 5646 primary spoken language
codes.

--quality arg
(=0)

Specifies the quality of libsamplerate conversion (0 =
best_quality, 4 = linear).

--disable_
multithreading

Disables multithreading and uses single thread for the resampling.

11.3 General steps for command-line tasks
The procedures for using command-line options include two general steps, both of which are system
dependent: opening the command-line program and navigating to the Dolby Atmos Conversion Tool
command-line application.

11.3.1 Opening the CLI
When working with Linux (desktop), Mac, or Windows, you will need to open a CLI before you use the Dolby
Atmos Conversion Tool command-line application. When working with the server version of Linux, there is
no program to open.

Procedure

Perform the step for your operating system:

• Linux (desktop version): Open the terminal window by pressing Ctrl + Alt + T.
• Mac: Open the Terminal application (located in the /Applications/Utilities folder)
• Windows: Open the Command Prompt from the Run Window.

11.3.2 Navigating to the Dolby Atmos Conversion Tool command-line
application
The step for navigating to the Dolby Atmos Conversion Tool command-line application is dependent on your
operating system.

Procedure

Perform the step for your operating system:
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• Linux: Type cd followed by the path where the cmdline_atmos_conversion_tool binary is located. For
example: cd /usr/bin/cmdline_atmos_conversion_tool.

• Mac: Type cd "/Applications/Dolby/Dolby Atmos Conversion Tool/".
• Windows: Type cd "Program Files\Dolby\Dolby Atmos Conversion Tool"

11.4 Using an .xml pmstitch file with command-line options
You can use an .xml (pmstitch) with the command line interface to perform a Dolby Atmos conversion
workflow.

About this task
This operation requires using an .xml (pmstitch) file and running the Dolby Atmos Conversion Tool command-
line application to create the new master.

Procedure

1. Open the command-line program if working with Linux (desktop version), Mac, or Windows.

Skip this step if you are working with the server version of Linux.

2. On a command-line, navigate to the Dolby Atmos Conversion Tool command-line application
(cmdline_atmos_conversion_tool).

3. Enter the commands for creating a new master:

On a command line, type the commands to start the Dolby Atmos Conversion Tool command-line
executable (cmdline_atmos_conversion_tool), add --pm, and then specify the location name of the source .xml
file, followed by the --output path and the master file path. Provide additional commands, as desired.

In this example, the source file path is defined in the .xml file, and the output path will be the current
working directory (which in this case, is the same folder as the .xml file). The master will be a home
theater .atmos master file set:

• Linux or Mac: ./cmdline_atmos_conversion_tool --pm_in example.xml --output_
pathexample.atmos

• Windows: cmdline_atmos_conversion_tool.exe --pm_in example.xml --output_pathexample.atmos

In this example, the source file path is defined in the .xml file, and the output path will be the current
working directory (which in this case, is the same folder as the .xml file). The master will be a .wav (ADM
BWF) master, with a first frame of action at 3600 seconds (01:00:00:00):

• Linux or Mac: ./cmdline_atmos_conversion_tool --pm_in example.xml --output_pathexample.wav --output_format wav
--ffoa 3600

• Windows: cmdline_atmos_conversion_tool --pm_in example.xml --output_pathexample.wav --output_format wav --ffoa
3600

4. Verify that the destination path directories you are using are not the directories where the source files are
located.

CAUTION: Double-check the destination path before pressing Enter in the next step. Using the
same path as your source files is destructive. (It will overwrite the existing files.)

5. Press <Enter> to begin the operation.

Successful completion is indicated with an information message.

6. When the path to the Dolby Atmos Conversion Tool command-line application directory returns to the
screen, you can perform more operations or close the command-line program.

Using an .xml pmstitch file with command-line options
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Glossary
A/V

Audio/video.

ADM
Audio Definition Model. A metadata model specified in ITU.R.BS.2076 that describes channel-, object-,
or scene-based audio file formats.

ADM BWF
Audio Definition Model Broadcast Wave Format.

BWF
Broadcast Wave Format. An extension of the Microsoft Waveform Audio Format (.wav) file format to
include metadata important to broadcast applications. This format is specified in EBU Tech 3285.

CLI
Command-line interface.

container
A formatted file (such as an MP4 file) comprising one or more multiplexed elementary streams and
including format-specific metadata.

DAW
Digital audio workstation. An electronic device or computer software application used to record, edit,
and produce audio files.

DCP
Digital Cinema Package. A packing list (PKL) file and all of the files that it references.

Dolby RMU
Dolby Rendering and Mastering Unit.

FFOA
First frame of action. The point on a film reel or corresponding file at which the program content begins.

fps
Frames per second. The number of unique consecutive audio or video frames an audio or imaging
device produces in one second.

frame rate
The number of frames decoded per second in real-time operation.

GUI
Graphical user interface.

IAB
Immersive audio bitstream. A frame-based audio bitstream that includes audio channels and/or audio
objects, plus metadata.

Glossary
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IMF
Interoperable Master Format. A SMPTE standard that defines an interoperable, file-based framework
designed to facilitate the management and processing of multiple versions of the same high-quality
finished work. See SMPTE ST 2067-2 and related documentation.

immersive stereo
A technology that delivers a virtualized immersive experience to headphones or stereo speakers
through a Dolby AC‑4 bitstream with appropriate stereo content and metadata that converts the stereo
signal into the virtualized experience.

ITU
International Telecommunication Union.

Line mode
A dynamic range control mode that applies metadata with a target dialogue level of -31 dBFS.

Lo/Ro
Left only/Right only. A downmix from a multichannel to a two-channel output that is compatible for
stereo or mono reproduction.

Lt/Rt
Left total/Right total. A stereo-compatible Dolby Surround downmix of the multichannel source
program that is suitable for Dolby Surround Pro Logic decoding.

mezzanine
Audio or video signals with an intermediate amount of compression for transport and distribution.
These lightly compressed signals are smaller in size but have enough quality for multiple compression
and decompression cycles in a postproduction chain without producing obvious artifacts. In video, the
signal is converted from the source during the color grading and mastering process. In audio, the signal
is converted during the ingestion process. Ingestion and conversion of audio and video may occur
simultaneously or separately, depending on the situation and workflow.

MXF
Material Exchange Format. A file format used to transfer and store different types of content (for
example, audio, video, data, or metadata). MXF currently supports various compression and encoding
formats, and its specification can be extended to new essence formats, if needed.

object
An audio signal plus associated object audio metadata.

rendering
Processing of audio content to adapt it to specific speaker layouts, such as 5.1‑ and 7.1‑speaker feeds,
or headphones and sound bars.

SMPTE
Society of Motion Picture and Television Engineers.

substream
A decodable unit that represents a specific channel configuration (mono, stereo, or 5.1) and contains
audio data and corresponding metadata.

UI
User interface.
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